aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/mesa/mesa/0006-fix-out-of-tree-egl.patch
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-08-09 16:32:24 +0100
committerSaul Wold <sgw@linux.intel.com>2013-08-13 07:29:32 -0700
commitfbc7092f0ae07538d4363679b1597ba4e556d1a8 (patch)
treec27fe059d872e4b9c0bce895034a79da4bc8685f /meta/recipes-graphics/mesa/mesa/0006-fix-out-of-tree-egl.patch
parent33fc0caa169c8d0c707977e387bda6a23630ee12 (diff)
downloadopenembedded-core-contrib-fbc7092f0ae07538d4363679b1597ba4e556d1a8.tar.gz
mesa: fix and enable out-of-tree builds
One patch (submitted upstream) for when Gallium is enabled, and another (inappropriate for upstream) to fix out-of-tree builds with 0003-EGL-Mutate-NativeDisplayType-depending-on-config. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/mesa/mesa/0006-fix-out-of-tree-egl.patch')
-rw-r--r--meta/recipes-graphics/mesa/mesa/0006-fix-out-of-tree-egl.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-graphics/mesa/mesa/0006-fix-out-of-tree-egl.patch b/meta/recipes-graphics/mesa/mesa/0006-fix-out-of-tree-egl.patch
new file mode 100644
index 0000000000..88a4fb0636
--- /dev/null
+++ b/meta/recipes-graphics/mesa/mesa/0006-fix-out-of-tree-egl.patch
@@ -0,0 +1,48 @@
+Fix out of tree compilation failure due to
+0003-EGL-Mutate-NativeDisplayType-depending-on-config.patch.
+
+Upstream-Status: Inappropriate (upstream has different solution to root problem)
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/src/egl/drivers/dri2/Makefile.am b/src/egl/drivers/dri2/Makefile.am
+index 45f7dfa..ed0e777 100644
+--- a/src/egl/drivers/dri2/Makefile.am
++++ b/src/egl/drivers/dri2/Makefile.am
+@@ -21,6 +21,7 @@
+
+ AM_CFLAGS = \
+ -I$(top_srcdir)/include \
++ -I$(top_builddir)/include \
+ -I$(top_srcdir)/src/egl/main \
+ -I$(top_srcdir)/src/gbm/main \
+ -I$(top_srcdir)/src/gbm/backends/dri \
+diff --git a/src/egl/drivers/glx/Makefile.am b/src/egl/drivers/glx/Makefile.am
+index 6bf67ea..7b87047 100644
+--- a/src/egl/drivers/glx/Makefile.am
++++ b/src/egl/drivers/glx/Makefile.am
+@@ -21,6 +21,7 @@
+
+ AM_CFLAGS = \
+ -I$(top_srcdir)/include \
++ -I$(top_builddir)/include \
+ -I$(top_srcdir)/src/egl/main \
+ $(X11_CFLAGS) \
+ $(DEFINES)
+diff --git a/src/egl/main/Makefile.am b/src/egl/main/Makefile.am
+index ca5257a..13a5734 100644
+--- a/src/egl/main/Makefile.am
++++ b/src/egl/main/Makefile.am
+@@ -27,6 +27,7 @@ endif
+
+ AM_CFLAGS = \
+ -I$(top_srcdir)/include \
++ -I$(top_builddir)/include \
+ -I$(top_srcdir)/src/gbm/main \
+ $(DEFINES) \
+ $(EGL_CFLAGS) \
+@@ -135,4 +136,4 @@ egl_HEADERS = \
+ $(top_srcdir)/include/EGL/eglext.h \
+ $(top_srcdir)/include/EGL/egl.h \
+ $(top_srcdir)/include/EGL/eglmesaext.h \
+- $(top_srcdir)/include/EGL/eglplatform.h
++ $(top_builddir)/include/EGL/eglplatform.h