aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/wayland/wayland
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-04-12 11:40:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-04-12 16:32:49 +0100
commitbfbe9b6a4fd7a8b5e5827847c2adff894e609e94 (patch)
tree1358d8ffde20d1e3edc510cef4a066444a279bfc /meta/recipes-graphics/wayland/wayland
parent31327bac1e5438a0041638332698a1e1e91640ba (diff)
downloadopenembedded-core-contrib-bfbe9b6a4fd7a8b5e5827847c2adff894e609e94.tar.gz
wayland: only build the scanner in wayland-native
We only build wayland-native for the scanner, so disable the bits we don't actually need. This gives us a small speed up but importantly should allow wayland-native to compile on older hosts such as CentOS 5 which currently fails. [ YOCTO #4245 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/wayland/wayland')
-rw-r--r--meta/recipes-graphics/wayland/wayland/just-scanner.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-graphics/wayland/wayland/just-scanner.patch b/meta/recipes-graphics/wayland/wayland/just-scanner.patch
new file mode 100644
index 0000000000..234a9c5f79
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland/just-scanner.patch
@@ -0,0 +1,36 @@
+We only build wayland-native for the scanner, so disable the bits we don't
+actually need. This gives us a small speed up but importantly should allow
+wayland-native to compile on older hosts such as CentOS 5 which currently fails:
+
+| wayland-1.0.6/src/wayland-server.c:1245: error: 'O_CLOEXEC' undeclared (first use in this function)
+| wayland-1.0.6/src/event-loop.c:34:25: error: sys/timerfd.h: No such file or directory
+| wayland-1.0.6/src/event-loop.c:199: error: 'CLOCK_MONOTONIC' undeclared (first use in this function)
+| wayland-1.0.6/src/event-loop.c:199: error: 'TFD_CLOEXEC' undeclared (first use in this function)
+| wayland-1.0.6/src/event-loop.c:268: error: 'SFD_CLOEXEC' undeclared (first use in this function)
+
+Upstream-Status: Inappropriate
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/Makefile.am b/Makefile.am
+index 306d7b3..571fe89 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,7 +2,7 @@ if BUILD_DOCS
+ doc_subdir = doc
+ endif
+
+-SUBDIRS = src protocol $(doc_subdir) tests cursor
++SUBDIRS = src protocol $(doc_subdir)
+
+ ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index e1d04ea..702342e 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -1,4 +1,4 @@
+-lib_LTLIBRARIES = libwayland-server.la libwayland-client.la
++#lib_LTLIBRARIES = libwayland-server.la libwayland-client.la
+ noinst_LTLIBRARIES = libwayland-util.la
+
+ include_HEADERS = \