aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/x11-common/x11-common_0.1.bb
diff options
context:
space:
mode:
authorJavier Martinez Canillas <javier@dowhile0.org>2012-08-05 21:48:48 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-06 14:37:12 +0100
commit5082056a4671570ca4578da2f622b3cc6f9f2dda (patch)
tree2e0b5bd03c88deede0060e650e44689c99f25749 /meta/recipes-graphics/x11-common/x11-common_0.1.bb
parent7556e60bf23c07646594a1704b3db7dfc29e631d (diff)
downloadopenembedded-core-contrib-5082056a4671570ca4578da2f622b3cc6f9f2dda.tar.gz
x11-common: use ${sysconfdir} instead of /etc for packaging
It is considered good practice to use the build system provided variables instead of directly specify hardcoded paths. Signed-off-by: Javier Martinez Canillas <javier@dowhile0.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics/x11-common/x11-common_0.1.bb')
-rw-r--r--meta/recipes-graphics/x11-common/x11-common_0.1.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-graphics/x11-common/x11-common_0.1.bb b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
index ddb3a1dffc..26751458c9 100644
--- a/meta/recipes-graphics/x11-common/x11-common_0.1.bb
+++ b/meta/recipes-graphics/x11-common/x11-common_0.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts and configuration files"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
SECTION = "x11"
-PR = "r44"
+PR = "r45"
SRC_URI = "file://etc \
file://gplv2-license.patch"
@@ -12,10 +12,10 @@ S = "${WORKDIR}"
inherit allarch
do_install() {
- cp -R ${S}/etc ${D}/etc
- chmod -R 755 ${D}/etc
- find ${D}/etc -type d -name .svn -prune -exec rm -rf {} \;
- find ${D}/etc -type f -name \*~ -exec rm -rf {} \;
+ cp -R ${S}/etc ${D}${sysconfdir}
+ chmod -R 755 ${D}${sysconfdir}
+ find ${D}${sysconfdir} -type d -name .svn -prune -exec rm -rf {} \;
+ find ${D}${sysconfdir} -type f -name \*~ -exec rm -rf {} \;
}
RDEPENDS_${PN} = "dbus-x11 xmodmap xdpyinfo xtscal xinit formfactor"