aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/xorg-lib
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2013-12-05 13:51:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-09 18:01:39 +0000
commit5050b4a023d8eff3198346bd6e631e87487deb94 (patch)
tree0a54087534618df3bcd7ae47c1a52a1ad275045f /meta/recipes-graphics/xorg-lib
parentce0b1ea834ee3ab2256b55fcd8b4092e091cf556 (diff)
downloadopenembedded-core-contrib-5050b4a023d8eff3198346bd6e631e87487deb94.tar.gz
xorg-lib-common.inc: use REQUIRED_DISTRO_FEATURES variable
Convert custom DISTRO_FEATURES test to distro_features_check.bbclass, and keep exceptions for libpciaccess and pixman. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-graphics/xorg-lib')
-rw-r--r--meta/recipes-graphics/xorg-lib/libpciaccess_0.13.2.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/pixman_0.32.4.bb2
-rw-r--r--meta/recipes-graphics/xorg-lib/xorg-lib-common.inc8
3 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.2.bb b/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.2.bb
index 6da86f24b6..d837bbd047 100644
--- a/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.2.bb
+++ b/meta/recipes-graphics/xorg-lib/libpciaccess_0.13.2.bb
@@ -10,3 +10,5 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=277aada5222b9a22fbf3471ff3687068"
SRC_URI[md5sum] = "b7c0d3afce14eedca57312a3141ec13a"
SRC_URI[sha256sum] = "abab8c2b050afb89bc29280e9c6b50ec5867174960d88bfb81a01036ec20de19"
+
+REQUIRED_DISTRO_FEATURES = ""
diff --git a/meta/recipes-graphics/xorg-lib/pixman_0.32.4.bb b/meta/recipes-graphics/xorg-lib/pixman_0.32.4.bb
index d1f3df7f9c..51cca5d13a 100644
--- a/meta/recipes-graphics/xorg-lib/pixman_0.32.4.bb
+++ b/meta/recipes-graphics/xorg-lib/pixman_0.32.4.bb
@@ -33,3 +33,5 @@ SRC_URI += "\
SRC_URI[md5sum] = "cdb566504fe9daf6728c7b03cc7ea228"
SRC_URI[sha256sum] = "ae2bd664057e330d41b40336ed296d3512318ce7f2401cc42601f2613d371e4c"
+
+REQUIRED_DISTRO_FEATURES = ""
diff --git a/meta/recipes-graphics/xorg-lib/xorg-lib-common.inc b/meta/recipes-graphics/xorg-lib/xorg-lib-common.inc
index 07b0373308..231776a21c 100644
--- a/meta/recipes-graphics/xorg-lib/xorg-lib-common.inc
+++ b/meta/recipes-graphics/xorg-lib/xorg-lib-common.inc
@@ -11,7 +11,7 @@ SRC_URI = "${XORG_MIRROR}/individual/lib/${XORG_PN}-${PV}.tar.bz2"
S = "${WORKDIR}/${XORG_PN}-${PV}"
-inherit autotools pkgconfig
+inherit autotools distro_features_check pkgconfig
EXTRA_OECONF = "--disable-specs --without-groff --without-ps2pdf --without-fop --without-xmlto"
EXTRA_OECONF_append_libc-glibc = " --disable-malloc0returnsnull"
@@ -20,8 +20,4 @@ EXTRA_OECONF_append_libc-uclibc = " --enable-malloc0returnsnull"
UNKNOWN_CONFIGURE_WHITELIST += "--enable-malloc0returnsnull --disable-malloc0returnsnull \
--disable-specs --without-groff --without-ps2pdf --without-fop --without-xmlto"
-python () {
- whitelist = [ "pixman", "libpciaccess" ]
- if not d.getVar('BPN', True) in whitelist and not oe.utils.contains ('DISTRO_FEATURES', 'x11', True, False, d):
- raise bb.parse.SkipPackage("'x11' not in DISTRO_FEATURES")
-}
+REQUIRED_DISTRO_FEATURES ?= "x11"