aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-02 21:04:59 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-06-03 16:45:04 +0100
commit2543b14dd0ca13005be0df027543431fc8e882ae (patch)
tree003ed12714ff59d4be59dcbf311d8cf1a73672fe /meta/recipes-graphics
parent0ced649c055dd25c500d0fd34e4ea94504d98580 (diff)
downloadopenembedded-core-contrib-2543b14dd0ca13005be0df027543431fc8e882ae.tar.gz
recipes: Add missing pkgconfig class inherits
These recipes all use pkg-config in some way but were missing dependencies on the tool, this patch adds them. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/directfb/directfb-examples_1.7.0.bb2
-rw-r--r--meta/recipes-graphics/fstests/fstests_git.bb2
-rw-r--r--meta/recipes-graphics/glew/glew_1.10.0.bb2
-rw-r--r--meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb2
-rw-r--r--meta/recipes-graphics/xrestop/xrestop_0.4.bb2
-rw-r--r--meta/recipes-graphics/xtscal/xtscal_0.6.3.bb2
6 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-graphics/directfb/directfb-examples_1.7.0.bb b/meta/recipes-graphics/directfb/directfb-examples_1.7.0.bb
index 6b4c7562ff..6057596071 100644
--- a/meta/recipes-graphics/directfb/directfb-examples_1.7.0.bb
+++ b/meta/recipes-graphics/directfb/directfb-examples_1.7.0.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ecf6fd2b19915afc4da56043926ca18f"
S = "${WORKDIR}/DirectFB-examples-${PV}"
-inherit autotools
+inherit autotools pkgconfig
SRC_URI[md5sum] = "8b60c867af295481c32a8c7fc5802307"
SRC_URI[sha256sum] = "9a2104cc4da8123c8371813551b66b943198979f745cbebc034bb5e10844122a"
diff --git a/meta/recipes-graphics/fstests/fstests_git.bb b/meta/recipes-graphics/fstests/fstests_git.bb
index 2f5a8727af..57ff9f6d54 100644
--- a/meta/recipes-graphics/fstests/fstests_git.bb
+++ b/meta/recipes-graphics/fstests/fstests_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = "file://test-pango-gdk.c;endline=24;md5=1ee74ec851ecda57eb7ac
S = "${WORKDIR}/git/tests"
-inherit autotools
+inherit autotools pkgconfig
diff --git a/meta/recipes-graphics/glew/glew_1.10.0.bb b/meta/recipes-graphics/glew/glew_1.10.0.bb
index de25069632..94f1bc1ed6 100644
--- a/meta/recipes-graphics/glew/glew_1.10.0.bb
+++ b/meta/recipes-graphics/glew/glew_1.10.0.bb
@@ -18,4 +18,4 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/project/glew/glew/${PV}/glew-${PV}.tgz \
SRC_URI[md5sum] = "2f09e5e6cb1b9f3611bcac79bc9c2d5d"
SRC_URI[sha256sum] = "99c41320b63f6860869b5fb9af9a1854b15582796c64ee3dfd7096dc0c89f307"
-inherit autotools lib_package
+inherit autotools lib_package pkgconfig
diff --git a/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb b/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
index 95abfce816..562434f16a 100644
--- a/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
+++ b/meta/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb
@@ -7,7 +7,7 @@ DEPENDS = "virtual/libx11 libxi"
PV = "0.7.5+git${SRCPV}"
PR = "r6"
-inherit autotools
+inherit autotools pkgconfig
SRCREV = "c01c5af807cb4b0157b882ab07a893df9a810111"
SRC_URI = "git://github.com/tias/xinput_calibrator.git \
diff --git a/meta/recipes-graphics/xrestop/xrestop_0.4.bb b/meta/recipes-graphics/xrestop/xrestop_0.4.bb
index 9600d0905f..20d66be55b 100644
--- a/meta/recipes-graphics/xrestop/xrestop_0.4.bb
+++ b/meta/recipes-graphics/xrestop/xrestop_0.4.bb
@@ -19,4 +19,4 @@ SRC_URI = "http://downloads.yoctoproject.org/releases/xrestop/xrestop-${PV}.tar.
SRC_URI[md5sum] = "d8a54596cbaf037e62b80c4585a3ca9b"
SRC_URI[sha256sum] = "67c2fc94a7ecedbaae0d1837e82e93d1d98f4a6d759828860e552119af3ce257"
-inherit autotools
+inherit autotools pkgconfig
diff --git a/meta/recipes-graphics/xtscal/xtscal_0.6.3.bb b/meta/recipes-graphics/xtscal/xtscal_0.6.3.bb
index e6ccd047b1..7e01775ce4 100644
--- a/meta/recipes-graphics/xtscal/xtscal_0.6.3.bb
+++ b/meta/recipes-graphics/xtscal/xtscal_0.6.3.bb
@@ -23,7 +23,7 @@ SRC_URI = "${GPE_MIRROR}/xtscal-${PV}.tar.bz2 \
SRC_URI[md5sum] = "9bcab80b474d5454477d1ca166a68c34"
SRC_URI[sha256sum] = "27b9dc2203de9b1706ca39fa6ca80ecab8807909ec901c4a345b8e41178800a1"
-inherit autotools
+inherit autotools pkgconfig
do_install_append() {
install -d ${D}${sysconfdir}/X11/Xsession.d/