aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-12-04 15:35:39 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-05 13:30:18 +0000
commitdbefa64dda9b0d5f12b37e3ef21831d78663afa6 (patch)
treee5a20ca89a9896fd8cd6feef5b4e863e895cdfe8 /meta/recipes-graphics
parent99e934712e4244bc4c9db4a2d735deb5cff8228a (diff)
downloadopenembedded-core-contrib-dbefa64dda9b0d5f12b37e3ef21831d78663afa6.tar.gz
libxft: fix Freetype header inclusion
Freetype 2.5.1 changes the location of the header files but as directly including the files isn't recommended they don't see this as a problem. Change libxft to use the recommended macros instead of direct inclusion, to fix the compilation. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-lib/libxft/freetype.patch39
-rw-r--r--meta/recipes-graphics/xorg-lib/libxft_2.3.1.bb8
2 files changed, 44 insertions, 3 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libxft/freetype.patch b/meta/recipes-graphics/xorg-lib/libxft/freetype.patch
new file mode 100644
index 0000000000..9f1aa21bac
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libxft/freetype.patch
@@ -0,0 +1,39 @@
+Upstream-Status: Submitted
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From f568fa5a8220fd06659c0f26a93adcc81a42917c Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Mon, 2 Dec 2013 13:48:40 +0000
+Subject: [PATCH] xftglyphs: use recommend freetype inclusion
+
+FreeType recommends to use their special macros to include the headers, because
+it gives them the ability to move headers around. They did this in 2.5.1 (yes,
+a point release) and this direct inclusion doesn't work anymore.
+
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+---
+ src/xftglyphs.c | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/xftglyphs.c b/src/xftglyphs.c
+index 2f3dc5a..53302f0 100644
+--- a/src/xftglyphs.c
++++ b/src/xftglyphs.c
+@@ -21,10 +21,10 @@
+ */
+
+ #include "xftint.h"
+-#include <freetype/ftoutln.h>
+-#include <freetype/ftlcdfil.h>
+-
+-#include <freetype/ftsynth.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
++#include FT_LCD_FILTER_H
++#include FT_SYNTHESIS_H
+
+ /*
+ * Validate the memory info for a font
+--
+1.8.5
+
diff --git a/meta/recipes-graphics/xorg-lib/libxft_2.3.1.bb b/meta/recipes-graphics/xorg-lib/libxft_2.3.1.bb
index 627a6d3d3c..16838f0eae 100644
--- a/meta/recipes-graphics/xorg-lib/libxft_2.3.1.bb
+++ b/meta/recipes-graphics/xorg-lib/libxft_2.3.1.bb
@@ -20,6 +20,11 @@ PROVIDES = "xft"
PE = "1"
+SRC_URI += "file://freetype.patch"
+
+SRC_URI[md5sum] = "78d64dece560c9e8699199f3faa521c0"
+SRC_URI[sha256sum] = "7fce32b92dcb7b2869bed567af2abc7bbad0d5d6fcf471b8a3e137964a31bbbd"
+
XORG_PN = "libXft"
BBCLASSEXTEND = "native"
@@ -28,6 +33,3 @@ python () {
if d.getVar('DEBIAN_NAMES', True):
d.setVar('PKG_${PN}', '${MLPREFIX}libxft2')
}
-
-SRC_URI[md5sum] = "78d64dece560c9e8699199f3faa521c0"
-SRC_URI[sha256sum] = "7fce32b92dcb7b2869bed567af2abc7bbad0d5d6fcf471b8a3e137964a31bbbd"