summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-08-06 23:07:56 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-08-08 10:17:56 +0100
commit30a2af80f5f8c8ddf0f619e4f50451b02baa22dd (patch)
treee0e0c1b703aae16914e1af513e2131176220fdb2 /meta/recipes-graphics
parent6cc148f8e7453ef4413ec44099a4899a4b435da2 (diff)
downloadopenembedded-core-contrib-30a2af80f5f8c8ddf0f619e4f50451b02baa22dd.tar.gz
libx11: replace libtool patch with upstreamed patch
After iterating with upstream, this is the patch that landed. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11.inc2
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11/fix-libtool.patch35
-rw-r--r--meta/recipes-graphics/xorg-lib/libx11/no-host-libtool.patch45
3 files changed, 46 insertions, 36 deletions
diff --git a/meta/recipes-graphics/xorg-lib/libx11.inc b/meta/recipes-graphics/xorg-lib/libx11.inc
index 994c33a8ef..cce0cb9929 100644
--- a/meta/recipes-graphics/xorg-lib/libx11.inc
+++ b/meta/recipes-graphics/xorg-lib/libx11.inc
@@ -11,7 +11,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/libx11:"
PE = "1"
SRC_URI += "file://Fix-hanging-issue-in-_XReply.patch \
- file://fix-libtool.patch \
+ file://no-host-libtool.patch \
file://no-host-x.patch"
SRC_URI[md5sum] = "c5fa5a86a20e3591bed6c046498d4b8f"
diff --git a/meta/recipes-graphics/xorg-lib/libx11/fix-libtool.patch b/meta/recipes-graphics/xorg-lib/libx11/fix-libtool.patch
deleted file mode 100644
index 678b7aff44..0000000000
--- a/meta/recipes-graphics/xorg-lib/libx11/fix-libtool.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Passing -all-static to libtool is done to avoid libtool wrappers on Windows, but
-it means that the build host needs to have libc.a installed. This isn't the
-case for a lot of distributions out of the box, so revert this commit.
-
-Filed a bug upstream to get a proper fix: https://gitlab.freedesktop.org/xorg/lib/libx11/issues/100
-
-Upstream-Status: Inappropriate
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-From b9f74dc5e714115057a5a1789b4de202d6f58547 Mon Sep 17 00:00:00 2001
-From: Ross Burton <ross.burton@intel.com>
-Date: Fri, 2 Aug 2019 00:39:39 +0100
-Subject: [PATCH 2/2] Revert "Avoid using libtool wrapper for makekeys"
-
-This reverts commit 4645e219133458781e3fb48eaea6a74cccb1b9aa.
----
- src/util/Makefile.am | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/util/Makefile.am b/src/util/Makefile.am
-index 37314370..a051567a 100644
---- a/src/util/Makefile.am
-+++ b/src/util/Makefile.am
-@@ -10,7 +10,7 @@ AM_CPPFLAGS = \
- CC = @CC_FOR_BUILD@
- CPPFLAGS = @CPPFLAGS_FOR_BUILD@
- CFLAGS = @CFLAGS_FOR_BUILD@
--LDFLAGS = @LDFLAGS_FOR_BUILD@ -all-static
-+LDFLAGS = @LDFLAGS_FOR_BUILD@
- LIBS =
- EXEEXT = @EXEEXT_FOR_BUILD@
-
---
-2.20.1
-
diff --git a/meta/recipes-graphics/xorg-lib/libx11/no-host-libtool.patch b/meta/recipes-graphics/xorg-lib/libx11/no-host-libtool.patch
new file mode 100644
index 0000000000..56d9983b13
--- /dev/null
+++ b/meta/recipes-graphics/xorg-lib/libx11/no-host-libtool.patch
@@ -0,0 +1,45 @@
+Upstream-Status: Backport [https://gitlab.freedesktop.org/xorg/lib/libx11/merge_requests/22]
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From edc7680ed5a03cedb5facf14693823455e12c29c Mon Sep 17 00:00:00 2001
+From: Ross Burton <ross.burton@intel.com>
+Date: Tue, 6 Aug 2019 14:53:43 +0100
+Subject: [PATCH libX11] src/util/Makefile: explicitly reset LINK to not use
+ libtool
+
+Simply looking at libtool redefines LINK globally to use libtool, which when
+you're trying to cross-compile to Windows can cause complications.
+
+As in src/util/ we're simply building a small binary for the build host, reset
+LINK to the automake default so that the traditional compile/link steps occur
+without libtool.
+
+Also remove -all-static from LDFLAGS as that is a libtool-specific argument
+intended to solve this problem.
+
+Closes: #100
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+---
+ src/util/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/util/Makefile.am b/src/util/Makefile.am
+index 37314370..b7236530 100644
+--- a/src/util/Makefile.am
++++ b/src/util/Makefile.am
+@@ -7,10 +7,11 @@ AM_CFLAGS = \
+ AM_CPPFLAGS = \
+ -I$(top_srcdir)/include
+
++LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+ CC = @CC_FOR_BUILD@
+ CPPFLAGS = @CPPFLAGS_FOR_BUILD@
+ CFLAGS = @CFLAGS_FOR_BUILD@
+-LDFLAGS = @LDFLAGS_FOR_BUILD@ -all-static
++LDFLAGS = @LDFLAGS_FOR_BUILD@
+ LIBS =
+ EXEEXT = @EXEEXT_FOR_BUILD@
+
+--
+2.20.1
+