summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linaro.org>2020-01-14 10:20:23 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-13 12:18:49 +0000
commitd3032809136707b584e7938c01e77da36abc1b00 (patch)
tree7b0b9fcca5b29316567d2560f965550344b91167 /meta/recipes-graphics
parenta60bf84b15be85ae0f16b5f85fec98b3365f15de (diff)
downloadopenembedded-core-contrib-d3032809136707b584e7938c01e77da36abc1b00.tar.gz
meta/recipes-graphics/waffle: Add python3 dependency
The python3native.bbclass set PYTHON_{LIBRARY, INCLUDE_DIR} pointing to python target build, a patch was add to use target _sysconfigdata too [1] but is not available without python3 dependency. Fixes waffle build when trying to find _sysconfigdata module, ... | Program python3 found: YES (/home/anibal.limon/linaro/oe-rpb-master/build-410c/tmp-rpb-glibc/work/aarch64-linaro-linux/waffle/1.6.0-r0/recipe-sysroot-native/usr/bin/python3-native/python3) | | meson.build:36:0: ERROR: <ExternalProgram 'python3' -> ['/home/anibal.limon/linaro/oe-rpb-master/build-410c/tmp-rpb-glibc/work/aarch64-linaro-linux/waffle/1.6.0-r0/recipe-sysroot-native/usr/bin/python3-native/python3']> is not a valid python or it is missing setuptools | | A full log can be found at /home/anibal.limon/linaro/oe-rpb-master/build-410c/tmp-rpb-glibc/work/aarch64-linaro-linux/waffle/1.6.0-r0/build/meson-logs/meson-log.txt | WARNING: exit code 1 from a shell command. ... [1] http://git.openembedded.org/openembedded-core/commit/?id=02714c105426b0d687620913c1a7401b386428b6 Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-graphics')
-rw-r--r--meta/recipes-graphics/waffle/waffle_1.6.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-graphics/waffle/waffle_1.6.0.bb b/meta/recipes-graphics/waffle/waffle_1.6.0.bb
index 52cb1df899..a620295978 100644
--- a/meta/recipes-graphics/waffle/waffle_1.6.0.bb
+++ b/meta/recipes-graphics/waffle/waffle_1.6.0.bb
@@ -11,6 +11,8 @@ UPSTREAM_CHECK_URI = "http://www.waffle-gl.org/releases.html"
inherit meson features_check lib_package bash-completion
+DEPENDS_append = " python3"
+
# This should be overridden per-machine to reflect the capabilities of the GL
# stack.
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11-egl', '', d)} \