aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/kmod/kmod_git.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-10-27 13:24:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-04 10:19:56 +0000
commit3576399ed163cb3136ee1a2077622035d2033158 (patch)
treec85d9dcc225798201d0e446c7097cd0516c37e0d /meta/recipes-kernel/kmod/kmod_git.bb
parent02767aac492cedf6ccd02648b8e65751cc23c11c (diff)
downloadopenembedded-core-contrib-3576399ed163cb3136ee1a2077622035d2033158.tar.gz
kmod: fix debuginfo is missing in shared library
INHIBIT_PACKAGE_STRIP variable will make debuginfo lose in shared library. The test cases of kmod contain kernel modules for many different architectures, strip and arch gets confused and throws errors. Pack kernel modules in test cases to avoid strip command failed. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/kmod/kmod_git.bb')
-rw-r--r--meta/recipes-kernel/kmod/kmod_git.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta/recipes-kernel/kmod/kmod_git.bb b/meta/recipes-kernel/kmod/kmod_git.bb
index d4c21a4387..08dd81569c 100644
--- a/meta/recipes-kernel/kmod/kmod_git.bb
+++ b/meta/recipes-kernel/kmod/kmod_git.bb
@@ -34,6 +34,10 @@ do_install_append () {
# install depmod.d file for search/ dir
install -Dm644 "${WORKDIR}/depmod-search.conf" "${D}${base_libdir}/depmod.d/search.conf"
+ if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then
+ find testsuite -name *.ko -exec tar rf testmodule.tar {} \;
+ find testsuite -name *.ko -exec rm -f {} \;
+ fi
}
do_compile_prepend() {
@@ -44,7 +48,10 @@ do_compile_ptest () {
oe_runmake buildtest-TESTS rootfs
}
-INHIBIT_PACKAGE_STRIP = "${@bb.utils.contains("DISTRO_FEATURES", "ptest", "1", "0", d)}"
+do_install_ptest () {
+ install testmodule.tar ${D}${PTEST_PATH}
+}
+
INSANE_SKIP_${PN}-ptest = "arch"
inherit update-alternatives