summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux-libc-headers
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2018-09-12 20:04:45 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-13 16:28:26 +0100
commit681ea847d760e69623b4ed110a6078f37ac3ec63 (patch)
tree90a1f6d603f99f34cf19f01fa73ad63a0c7929fe /meta/recipes-kernel/linux-libc-headers
parent5f1895fb94d35a1496f22863791ad6f7a6aca97a (diff)
downloadopenembedded-core-contrib-681ea847d760e69623b4ed110a6078f37ac3ec63.tar.gz
linux-libc-headers: Don't do useless configuration
There's no point in configuring Linux kernel before headers installation. Moreover in come cases it might lead to problems on kernels starting from 4.17 with architecture or platfrom sets CROSS_COMPILE variable automatically, see [1]. Also note Buildroot doesn't do that kind of configuration as well, see [2]. And while at it convert empty do_compile to noexec as well. [1] https://lkml.org/lkml/2018/9/12/486 [2] https://git.buildroot.org/buildroot/tree/package/linux-headers/linux-headers.mk#n106 Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux-libc-headers')
-rw-r--r--meta/recipes-kernel/linux-libc-headers/linux-libc-headers.inc7
1 files changed, 2 insertions, 5 deletions
diff --git a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers.inc b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers.inc
index 05c82558e6..be215af9b9 100644
--- a/meta/recipes-kernel/linux-libc-headers/linux-libc-headers.inc
+++ b/meta/recipes-kernel/linux-libc-headers/linux-libc-headers.inc
@@ -53,12 +53,9 @@ S = "${WORKDIR}/linux-${PV}"
EXTRA_OEMAKE = " HOSTCC="${BUILD_CC}" HOSTCPP="${BUILD_CPP}""
-do_configure() {
- oe_runmake allnoconfig
-}
+do_configure[noexec] = "1"
-do_compile () {
-}
+do_compile[noexec] = "1"
do_install() {
oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}