summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto_5.2.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2019-10-08 10:26:29 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-08 20:47:52 +0100
commit55a54aed27ffa94a235da526a39aeea59caa3417 (patch)
tree655fe22d3109b7d642e7ba232b5b61785dd642e8 /meta/recipes-kernel/linux/linux-yocto_5.2.bb
parentaba70cbbc1ef6139aad862160427eb70faafda84 (diff)
downloadopenembedded-core-contrib-55a54aed27ffa94a235da526a39aeea59caa3417.tar.gz
linux-yocto/5.2: fix strace/ptrace long runtime issues
Bumping SRCREVs to pickup the following kernel commit: [ Author: Bruce Ashfield <bruce.ashfield@gmail.com> Date: Tue Oct 8 13:15:46 2019 +0000 signal/ptrace: fix cgroup2/freezer long runtimes As reported in the thread: https://lkml.org/lkml/2019/10/1/789, in kernels with commit 76f969e8948d82 [cgroup: cgroup v2 freezer], we were seeing much longer runtime in strace/ptrace tests (4 minutes versus 4 seconds). The issue only manifests if CONFIG_PREEMPT is enabled, which is in all of the default configurations. As sugggested in the thread, the movement of preempt_enable_no_resched() until after the cgroup is frozen returns the behaviour to pre-5.2 runtimes. Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> ] With this change in place, our times are back to normal: root@qemux86-64:~# cd /usr/lib/strace/ptest/tests root@qemux86-64:/usr/lib/strace/ptest/tests# time ../strace -o log -qq -esignal=none -e/clock ./printpath-umovestr>ttt real 0m3.909s user 0m0.534s sys 0m3.342s This will eventually loop around via -stable, or may need future tweaks, but it does address the immediate issue/symptom that we are seeing, with no obvious side effects. [YOCTO #13556] Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto_5.2.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_5.2.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto_5.2.bb b/meta/recipes-kernel/linux/linux-yocto_5.2.bb
index 49b14b6185..1a2c3ffcd2 100644
--- a/meta/recipes-kernel/linux/linux-yocto_5.2.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_5.2.bb
@@ -12,16 +12,16 @@ KBRANCH_qemux86 ?= "v5.2/standard/base"
KBRANCH_qemux86-64 ?= "v5.2/standard/base"
KBRANCH_qemumips64 ?= "v5.2/standard/mti-malta64"
-SRCREV_machine_qemuarm ?= "d956bb318771761069228fc70fea722ceabecb75"
-SRCREV_machine_qemuarm64 ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
-SRCREV_machine_qemumips ?= "9e95334637a4a85b19bea120f9027ff0028d7069"
-SRCREV_machine_qemuppc ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
-SRCREV_machine_qemuriscv64 ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
-SRCREV_machine_qemux86 ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
-SRCREV_machine_qemux86-64 ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
-SRCREV_machine_qemumips64 ?= "29a8d126f60d1b9e9cf0985b38da2033ebde25db"
-SRCREV_machine ?= "25b14cdf9659c68ab32d66616dfdbbe2ece3fd94"
-SRCREV_meta ?= "56f5bc749e5a8e40b55a3819288ac277813ec5ef"
+SRCREV_machine_qemuarm ?= "47b80ef7bd932830f299ed76e2302df631ae4fbe"
+SRCREV_machine_qemuarm64 ?= "255a750d28cd45df8923c3aba1e82c322757a50d"
+SRCREV_machine_qemumips ?= "45ff64cb3f87c38db6f46353ea93005d049b0cf6"
+SRCREV_machine_qemuppc ?= "255a750d28cd45df8923c3aba1e82c322757a50d"
+SRCREV_machine_qemuriscv64 ?= "255a750d28cd45df8923c3aba1e82c322757a50d"
+SRCREV_machine_qemux86 ?= "255a750d28cd45df8923c3aba1e82c322757a50d"
+SRCREV_machine_qemux86-64 ?= "255a750d28cd45df8923c3aba1e82c322757a50d"
+SRCREV_machine_qemumips64 ?= "ea0fd387a459803ac60e9b8a1729f2fc7d3215f1"
+SRCREV_machine ?= "255a750d28cd45df8923c3aba1e82c322757a50d"
+SRCREV_meta ?= "b867b78b5019ae455af97dec7794cff7527d7624"
# remap qemuarm to qemuarma15 for the 5.2 kernel
# KMACHINE_qemuarm ?= "qemuarma15"