summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng
diff options
context:
space:
mode:
authorAmarnath Valluri <amarnath.valluri@intel.com>2017-02-14 16:07:56 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-21 22:43:01 +0000
commitd0f99c7f264fb99e7a940e9b02d27a418bafad27 (patch)
tree4d396483a6f5787f19d73454d09e4443a56d8edc /meta/recipes-kernel/lttng
parent8be0740f8cc8d909a8983b499f200b99261124c4 (diff)
downloadopenembedded-core-contrib-d0f99c7f264fb99e7a940e9b02d27a418bafad27.tar.gz
lttng-modules: Replace '/lib' with ${nonarch_base_libdir}
Do not assume '/lib' for kernel modules location, instead use ${nonarch_base_libdir}. When 'usrmerge' is enabled, kernel modules are not located in /lib/modules, but /usr/lib/modules. Signed-off-by: Amarnath Valluri <amarnath.valluri@intel.com>
Diffstat (limited to 'meta/recipes-kernel/lttng')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.9.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.9.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.9.1.bb
index 8e47c6f0a1..abff79d06f 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.9.1.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.9.1.bb
@@ -22,11 +22,11 @@ EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
do_install_append() {
# Delete empty directories to avoid QA failures if no modules were built
- find ${D}/lib -depth -type d -empty -exec rmdir {} \;
+ find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
}
python do_package_prepend() {
- if not os.path.exists(os.path.join(d.getVar('D'), 'lib/modules')):
+ if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
}