summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/powertop
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2014-12-18 15:54:14 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-19 18:06:46 +0000
commita3e9b391e1024d6d2e256b75c214d34e6693e332 (patch)
tree8aa116c7a602332e4b017a83d1364a72254f00b1 /meta/recipes-kernel/powertop
parent6214649b3aed5075c86aed79aa1356f1e5a19f9d (diff)
downloadopenembedded-core-contrib-a3e9b391e1024d6d2e256b75c214d34e6693e332.tar.gz
powertop: Fix build for !uclibc
* EXTRA_LDFLAGS isn't defined for !uclibc and configure fails when it reads it unexpanded, see config.log snippet: configure:4177: checking whether the C compiler works configure:4199: i586-oe-linux-gcc -m32 -march=i586 --sysroot=/OE/sysroots/qemux86 -O2 -pipe -g -feliminate-unused-debug-types -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed ${EXTRA_LDFLAGS} conftest.c >&5 i586-oe-linux-gcc: error: ${EXTRA_LDFLAGS}: No such file or directory configure:4203: $? = 1 configure:4241: result: no Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/powertop')
-rw-r--r--meta/recipes-kernel/powertop/powertop_2.7.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-kernel/powertop/powertop_2.7.bb b/meta/recipes-kernel/powertop/powertop_2.7.bb
index dce5d715fd..5ba07e9ab9 100644
--- a/meta/recipes-kernel/powertop/powertop_2.7.bb
+++ b/meta/recipes-kernel/powertop/powertop_2.7.bb
@@ -14,8 +14,9 @@ SRC_URI[sha256sum] = "8d4b1490e2baad4467c0ded3c423db4472dcbf7b2dd8f8f2a928f54047
inherit autotools gettext pkgconfig
# we need to explicitly link with libintl in uClibc systems
-LDFLAGS += "${EXTRA_LDFLAGS}"
+EXTRA_LDFLAGS ?= ""
EXTRA_LDFLAGS_libc-uclibc = "-lintl"
+LDFLAGS += "${EXTRA_LDFLAGS}"
# we do not want libncursesw if we can
do_configure_prepend() {