aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
authorWade Farnsworth <wade_farnsworth@mentor.com>2012-02-06 07:49:14 -0700
committerSaul Wold <sgw@linux.intel.com>2012-02-07 14:37:13 -0800
commit3cc4ba935444240b93abdc726342658ada803118 (patch)
treedc779884027f438c0125ff989a819dda2280ec9c /meta/recipes-kernel/systemtap/systemtap_git.bb
parent507bd29c5d1a3459e376e2d2c338b7e2a0afabaa (diff)
downloadopenembedded-core-contrib-3cc4ba935444240b93abdc726342658ada803118.tar.gz
systemtap: build and install uprobes.ko
SystemTap needs to provide uprobes.ko in order to support user space probing. Build and install the module on systems that support it. Additionally, split off common bits into systemtap_git.inc. Signed-off-by: Wade Farnsworth <wade_farnsworth@mentor.com>
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb18
1 files changed, 3 insertions, 15 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index fb3c0efaa2..c4a9d87dfd 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -1,16 +1,12 @@
DESCRIPTION = "SystemTap - script-directed dynamic tracing and performance analysis tool for Linux"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+require systemtap_git.inc
DEPENDS = "elfutils sqlite3 systemtap-native"
DEPENDS_virtclass-native = "elfutils-native sqlite3-native gettext-native"
DEPENDS_virtclass-nativesdk = "elfutils-nativesdk sqlite3-nativesdk gettext-nativesdk"
-SRCREV = "83bd2699d8cff2f2d6b9eaf5ea254e4cb6b33e81"
-PR = "r1"
-PV = "1.7+git${SRCPV}"
-
-SRC_URI = "git://sources.redhat.com/git/systemtap.git;protocol=git"
+PR = "r2"
EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
ac_cv_file__usr_include_nss=no \
@@ -20,14 +16,6 @@ EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
ac_cv_file__usr_include_avahi_client=no \
ac_cv_file__usr_include_avahi_common=no "
-SRC_URI[md5sum] = "cb202866ed704c44a876d041f788bdee"
-SRC_URI[sha256sum] = "8ffe35caec0d937bd23fd78a3a8d94b58907cc0de0330b35e38f9f764815c459"
-
-# systemtap doesn't support mips
-COMPATIBLE_HOST = '(x86_64.*|i.86.*|powerpc.*|arm.*)-linux'
-
-S = "${WORKDIR}/git"
-
inherit autotools gettext
BBCLASSEXTEND = "native nativesdk"