aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-01 11:34:57 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-03-02 12:54:03 +0000
commit8a0d31af7008459d1affa0afe3ff193a78f9020d (patch)
tree5930d6b487a912e482a2ded1d41ada3351057861 /meta/recipes-kernel/systemtap/systemtap_git.bb
parentb2f5c8f7dfda0bc8f07561336c8667c864d9c3bb (diff)
downloadopenembedded-core-contrib-8a0d31af7008459d1affa0afe3ff193a78f9020d.tar.gz
systemtap: add python and bash dependencies
There are a number of scripts in the systemtap installation that use python and bash, so we need to add run-time dependencies for them. If not, we can generate build errors like "no package provides /usr/bin/python". Fixes [YOCTO #3951]. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 7fc92c8487..22f89599cf 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -6,6 +6,10 @@ DEPENDS = "elfutils sqlite3 systemtap-native"
DEPENDS_class-native = "elfutils-native sqlite3-native gettext-native"
DEPENDS_class-nativesdk = "nativesdk-elfutils nativesdk-sqlite3 nativesdk-gettext"
+RDEPENDS_${PN} += "python bash"
+RDEPENDS_${PN}_class-native += "python-native"
+RDEPENDS_${PN}_class-nativesdk += "python-native"
+
PR = "r1"
EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \