aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
authorWade Farnsworth <wade_farnsworth@mentor.com>2012-02-06 07:48:20 -0700
committerSaul Wold <sgw@linux.intel.com>2012-02-07 14:37:13 -0800
commit507bd29c5d1a3459e376e2d2c338b7e2a0afabaa (patch)
tree89ae6cbd4122a3b15ae2082e87d435db3c3a4100 /meta/recipes-kernel/systemtap/systemtap_git.bb
parentea57a29c75aa8265aecb8b0acd9c29340e98092c (diff)
downloadopenembedded-core-contrib-507bd29c5d1a3459e376e2d2c338b7e2a0afabaa.tar.gz
systemtap: extend the recipe to build the native package
Since the target image may not contain dev tools, it is useful to provide native systemtap in order to be able to compile systemtap scripts for the target. Signed-off-by: Wade Farnsworth <wade_farnsworth@mentor.com>
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index dff08eec49..fb3c0efaa2 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -2,10 +2,12 @@ DESCRIPTION = "SystemTap - script-directed dynamic tracing and performance analy
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
-DEPENDS = "elfutils sqlite3"
+DEPENDS = "elfutils sqlite3 systemtap-native"
+DEPENDS_virtclass-native = "elfutils-native sqlite3-native gettext-native"
+DEPENDS_virtclass-nativesdk = "elfutils-nativesdk sqlite3-nativesdk gettext-nativesdk"
SRCREV = "83bd2699d8cff2f2d6b9eaf5ea254e4cb6b33e81"
-PR = "r0"
+PR = "r1"
PV = "1.7+git${SRCPV}"
SRC_URI = "git://sources.redhat.com/git/systemtap.git;protocol=git"
@@ -28,4 +30,6 @@ S = "${WORKDIR}/git"
inherit autotools gettext
+BBCLASSEXTEND = "native nativesdk"
+
FILES_${PN}-dbg += "${libexecdir}/systemtap/.debug"