aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/systemtap/systemtap_git.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-02-24 18:02:03 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 12:54:23 +0000
commite3bccfba499565ea13f154a11dadcab48ef5e0ab (patch)
treef6aefd368a5f43acd29f31a3699ea379494c38c7 /meta/recipes-kernel/systemtap/systemtap_git.bb
parent25c71d320198d41cf760dbea96840d352681dced (diff)
downloadopenembedded-core-contrib-e3bccfba499565ea13f154a11dadcab48ef5e0ab.tar.gz
systemtap: update to 3.1
Removed patches are in upstream. Rebase monitor-option.patch and no-msgfmt-check.patch Add support for python 3 probes (this necessitates the 0001-Do-not-let-configure-write-a-python-location-into-th.patch and the Add 0001-Install-python-modules-to-correct-library-dir.patch to install python modules to correct destination). Add perl to RDEPENDS to fix a QA warning about one of the installed files. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-kernel/systemtap/systemtap_git.bb')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 43bf69e877..fed368a38b 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -4,12 +4,12 @@ require systemtap_git.inc
DEPENDS = "boost elfutils"
-RDEPENDS_${PN} += "python3-core bash"
+RDEPENDS_${PN} += "python3-core bash perl"
EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
--without-nss --without-avahi --without-dyninst \
--disable-server --disable-grapher --enable-prologues \
- --with-python3 \
+ --with-python3 --without-python2-probes \
ac_cv_prog_have_javac=no \
ac_cv_prog_have_jar=no "
@@ -17,11 +17,12 @@ STAP_DOCS ?= "--disable-docs --disable-publican --disable-refdocs"
EXTRA_OECONF += "${STAP_DOCS} "
-PACKAGECONFIG ??= "sqlite monitor"
+PACKAGECONFIG ??= "sqlite monitor python3-probes"
PACKAGECONFIG[libvirt] = "--enable-libvirt,--disable-libvirt,libvirt"
PACKAGECONFIG[sqlite] = "--enable-sqlite,--disable-sqlite,sqlite3"
PACKAGECONFIG[monitor] = "--enable-monitor,--disable-monitor,ncurses json-c"
+PACKAGECONFIG[python3-probes] = "--with-python3-probes,--without-python3-probes,python3-setuptools-native"
-inherit autotools gettext pkgconfig
+inherit autotools gettext pkgconfig distutils3-base
BBCLASSEXTEND = "native nativesdk"