aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-lsb4/perl
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-08-31 18:00:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-10 13:01:53 +0100
commitc3e066aa0589a5c1f8d72f3736e130194828e4d3 (patch)
tree487c14f3632c819dfcc2a8dbae8979021f7f0635 /meta/recipes-lsb4/perl
parent23a6f63f74e42c62167a49c71ca13c86bdf2f851 (diff)
downloadopenembedded-core-contrib-c3e066aa0589a5c1f8d72f3736e130194828e4d3.tar.gz
libclass-isa-perl: add it
perl module Class::ISA is needed by LSB 4.1 perl test, so add it. When LSB 5.0 release, it will be deprecated. But we need it now. [Yocto #3030] (From OE-Core rev: f2e8d7670d926aa88c3c38996d1a216812741dd2) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-lsb4/perl')
-rw-r--r--meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb b/meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb
new file mode 100644
index 0000000000..0a9c5cc52a
--- /dev/null
+++ b/meta/recipes-lsb4/perl/libclass-isa-perl_0.36.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Perl module for reporting the search path for a class's ISA tree"
+DESCRIPTION = "Suppose you have a class (like Food::Fish::Fishstick) that is derived, \
+via its @ISA, from one or more superclasses (as Food::Fish::Fishstick is from Food::Fish,\
+Life::Fungus, and Chemicals), and some of those superclasses may themselves each be\
+derived, via its @ISA, from one or more superclasses (as above).\
+\
+When, then, you call a method in that class ($fishstick->calories), Perl first searches\
+there for that method, but if it's not there, it goes searching in its superclasses, and\
+so on, in a depth-first (or maybe "height-first" is the word) search. In the above example,\
+it'd first look in Food::Fish, then Food, then Matter, then Life::Fungus, then Life, then\
+Chemicals.\
+\
+This library, Class::ISA, provides functions that return that list -- the list\
+(in order) of names of classes Perl would search to find a method, with no duplicates."
+
+HOMEPAGE = "http://search.cpan.org/dist/Class-ISA/"
+SECTION = "libs"
+LICENSE = "Artistic-1.0 | GPL-1.0+"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://README;beginline=107;endline=111;md5=6a5c6842a63cfe4dab1f66e2350e4d25"
+
+SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/Class-ISA-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "3a2ad203c8dc87d6c9de16215d00af47"
+SRC_URI[sha256sum] = "8816f34e9a38e849a10df756030dccf9fe061a196c11ac3faafd7113c929b964"
+
+S = "${WORKDIR}/Class-ISA-${PV}"
+
+inherit cpan
+
+BBCLASSEXTEND = "native"