summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libomxil/libomxil-0.9.3/configure-fix.patch
diff options
context:
space:
mode:
authorShane Wang <shane.wang@intel.com>2011-12-28 15:59:33 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:10:48 +0000
commit2eb0f4b5b231ae4a6d711e0dff06eb7bafb18007 (patch)
treef0c1a333ded084a5e1738208203c74b05ef9979e /meta/recipes-multimedia/libomxil/libomxil-0.9.3/configure-fix.patch
parent787ed39a2b1a598482dfc3354c4698e3a586a096 (diff)
downloadopenembedded-core-contrib-2eb0f4b5b231ae4a6d711e0dff06eb7bafb18007.tar.gz
libomxil: upgrade to 0.9.3
This patch is to upgrade libomxil from 0.3.3 to 0.9.3. The following is the licence change: 2c2 < @file src/omxcore.h --- > src/omxcore.h 4c4 < OpenMax Integration Layer Core. This library implements the OpenMAX core --- > OpenMAX Integration Layer Core. This library implements the OpenMAX core 7c7,8 < Copyright (C) 2007 STMicroelectronics and Nokia --- > Copyright (C) 2007-2009 STMicroelectronics > Copyright (C) 2007-2009 Nokia Corporation and/or its subsidiary(-ies). 24,26d24 < $Date: 2007-05-22 16:48:41 +0200 (Tue, 22 May 2007) $ < Revision $Rev: 239 $ < Author $Author: gsent $ 34d31 < 36d32 Signed-off-by: Shane Wang <shane.wang@intel.com>
Diffstat (limited to 'meta/recipes-multimedia/libomxil/libomxil-0.9.3/configure-fix.patch')
-rw-r--r--meta/recipes-multimedia/libomxil/libomxil-0.9.3/configure-fix.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-multimedia/libomxil/libomxil-0.9.3/configure-fix.patch b/meta/recipes-multimedia/libomxil/libomxil-0.9.3/configure-fix.patch
new file mode 100644
index 0000000000..876e80ef76
--- /dev/null
+++ b/meta/recipes-multimedia/libomxil/libomxil-0.9.3/configure-fix.patch
@@ -0,0 +1,58 @@
+To enable --disable-Werror for libomxil to avoid some compilers which check code strictly.
+
+For example, at least the following errors happened to some compilers:
+
+1) OMX_INDEXTYPE in include/OMX_Index.h IS NOT OMX_INDEXVENDORTYPE in src/base/omx_base_component.h
+| i586-poky-linux-libtool: compile: i586-poky-linux-gcc -m32 -march=i586 --sysroot=/home/yocto-build5/poky/build/tmp/sysroots/qemux86 -DHAVE_Climinate-unused-debug-types -Wall -Werror -DCONFIG_DEBUG_LEVEL=0 -c OMXComponentRMExt.c -fPIC -DPIC -o .libs/libomxbase_la-OMXComponentRMExt.o
+| omx_base_component.c: In function 'omx_base_component_GetParameter':
+| omx_base_component.c:991:3: error: case value '2130706435' not in enumerated type 'OMX_INDEXTYPE' [-Werror=switch]
+| omx_base_component.c:918:3: error: case value '2130706436' not in enumerated type 'OMX_INDEXTYPE' [-Werror=switch]
+
+2)
+| i586-poky-linux-gcc -m32 -march=i586 --sysroot=/home/yocto-build5/poky/build/tmp/sysroots/qemux86 -DHAVE_CONFIG_H -I. -I.. -DOMXILCOMPOminate-unused-debug-types -Wall -Werror -DCONFIG_DEBUG_LEVEL=0 -c -o omxregister_bellagio-omxregister.o `test -f 'omxregister.c' || echo './'`o
+| omxregister.c: In function 'buildComponentsList':
+| omxregister.c:175:7: error: variable 'err' set but not used [-Werror=unused-but-set-variable]
+| cc1: all warnings being treated as errors
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Shane Wang <shane.wang@intel.com>
+
+diff -r 82d742d3ea90 configure.ac
+--- a/configure.ac Tue Dec 27 15:30:35 2011 +0800
++++ b/configure.ac Tue Dec 27 16:26:03 2011 +0800
+@@ -5,7 +5,7 @@
+ AC_PREREQ([2.59])
+
+ AC_CONFIG_HEADERS([config.h])
+-CFLAGS="${CFLAGS} -Wall -Werror"
++CFLAGS="${CFLAGS} -Wall"
+
+ ################################################################################
+ # Set the shared versioning info, according to section 6.3 of the libtool info #
+@@ -122,6 +122,14 @@
+ [with_android=$enableval],
+ [with_android=no])
+
++AC_ARG_ENABLE(
++ [Werror],
++ [AC_HELP_STRING(
++ [--disable-Werror],
++ [whether to diable treating gcc warnings as errors])],
++ [with_Werror=$enableval],
++ [with_Werror=yes])
++
+ ################################################################################
+ # Check for programs #
+ ################################################################################
+@@ -193,6 +201,10 @@
+ CFG_DEBUG_LEVEL=255
+ fi
+
++if test "x$with_Werror" = "xyes"; then
++ CFLAGS="${CFLAGS} -Werror"
++fi
++
+ AC_SUBST(CFG_DEBUG_LEVEL)
+ CFLAGS="${CFLAGS} -DCONFIG_DEBUG_LEVEL=$CFG_DEBUG_LEVEL"
+