summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb
diff options
context:
space:
mode:
authorDrew Moseley <drew_moseley@mentor.com>2014-07-20 16:13:36 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-07-21 19:03:51 +0100
commitaa99817ad02c153361b2707d6fc81c09e72f4b8f (patch)
tree53c32b36b551ac6c07f18f719f2eccc1afcb09cc /meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb
parentd4f4ad5edd8914e696722c1a1c3ba7de091d4c19 (diff)
downloadopenembedded-core-contrib-aa99817ad02c153361b2707d6fc81c09e72f4b8f.tar.gz
libomxil-0.9.3: Remove versioning for .so files.
The so files installed by libomxil are not versioned and should be installed without version-based symlinks so that omxregister-bellagio can properly find and register them. Signed-off-by: Drew Moseley <drew_moseley@mentor.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb')
-rw-r--r--meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb17
1 files changed, 11 insertions, 6 deletions
diff --git a/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb b/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb
index 103d789482..ba3d4911f5 100644
--- a/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb
+++ b/meta/recipes-multimedia/libomxil/libomxil_0.9.3.bb
@@ -12,7 +12,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/omxil/libomxil-bellagio-${PV}.tar.gz \
file://configure-fix.patch \
file://parallel-make.patch \
file://makefile-docdir-fix.patch \
- file://dynamicloader-linking.patch"
+ file://dynamicloader-linking.patch \
+ file://disable-so-versioning.patch"
SRC_URI[md5sum] = "a1de827fdb75c02c84e55f740ca27cb8"
SRC_URI[sha256sum] = "593c0729c8ef8c1467b3bfefcf355ec19a46dd92e31bfc280e17d96b0934d74c"
@@ -23,13 +24,17 @@ inherit autotools
EXTRA_OECONF += "--disable-doc --disable-Werror"
-FILES_${PN} += "${libdir}/bellagio/*${SOLIBS} \
- ${libdir}/omxloaders/*${SOLIBS}"
+#
+# The .so files populated by libomxil are not intended to be versioned and symlinked.
+# Make sure they get packaged in the main package.
+#
+FILES_SOLIBSDEV = ""
+FILES_${PN} += "${libdir}/*.so \
+ ${libdir}/bellagio/*.so \
+ ${libdir}/omxloaders/*.so"
FILES_${PN}-staticdev += "${libdir}/bellagio/*.a \
${libdir}/omxloaders/*.a"
FILES_${PN}-dev += "${libdir}/bellagio/*.la \
- ${libdir}/bellagio/*${SOLIBSDEV} \
- ${libdir}/omxloaders/*.la \
- ${libdir}/omxloaders/*${SOLIBSDEV}"
+ ${libdir}/omxloaders/*.la"
FILES_${PN}-dbg += "${libdir}/bellagio/.debug/ \
${libdir}/omxloaders/.debug/"