summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/mpg123
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-05-01 14:18:35 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-01 23:10:13 +0100
commit1aa947a60b0eb31c367b1e9818218ee74d388eea (patch)
treec671720fb0176a96eddb9698b040484020e9e46a /meta/recipes-multimedia/mpg123
parentffa4b0abcab2ed4e4f642b4b3140aa6095938422 (diff)
downloadopenembedded-core-contrib-1aa947a60b0eb31c367b1e9818218ee74d388eea.tar.gz
mpg123: port to use libsdl2
libsdl 1.2 is dead upstream, so change mpg123 to use libsdl2. Luckily the APIs that mpg123 use haven't changed, so this is just a matter of changing the pkg-config name. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia/mpg123')
-rw-r--r--meta/recipes-multimedia/mpg123/mpg123/sdl2.patch14
-rw-r--r--meta/recipes-multimedia/mpg123/mpg123_1.25.10.bb5
2 files changed, 17 insertions, 2 deletions
diff --git a/meta/recipes-multimedia/mpg123/mpg123/sdl2.patch b/meta/recipes-multimedia/mpg123/mpg123/sdl2.patch
new file mode 100644
index 0000000000..9dc9b923df
--- /dev/null
+++ b/meta/recipes-multimedia/mpg123/mpg123/sdl2.patch
@@ -0,0 +1,14 @@
+Use libsdl2 instead of libsdl 1.2, which is dead upstream.
+
+Luckily the API that mpg123 use didn't change so this is a trivial change.
+
+Upstream-Status: Submitted [https://sourceforge.net/p/mpg123/bugs/268/]
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/configure.ac b/configure.ac
+index 6216d4f..b8d3344 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1694 +1694 @@ do
+- PKG_CHECK_MODULES(SDL, sdl, output_modules="$output_modules sdl" HAVE_SDL="yes", HAVE_SDL="no" check_failed=yes)
++ PKG_CHECK_MODULES(SDL, sdl2, output_modules="$output_modules sdl" HAVE_SDL="yes", HAVE_SDL="no" check_failed=yes)
diff --git a/meta/recipes-multimedia/mpg123/mpg123_1.25.10.bb b/meta/recipes-multimedia/mpg123/mpg123_1.25.10.bb
index ff2b7d893b..dfb10bb1cd 100644
--- a/meta/recipes-multimedia/mpg123/mpg123_1.25.10.bb
+++ b/meta/recipes-multimedia/mpg123/mpg123_1.25.10.bb
@@ -9,7 +9,8 @@ SECTION = "multimedia"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=1e86753638d3cf2512528b99079bc4f3"
-SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2"
+SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2 \
+ file://sdl2.patch"
SRC_URI[md5sum] = "ea32caa61d41d8be797f0b04a1b43ad9"
SRC_URI[sha256sum] = "6c1337aee2e4bf993299851c70b7db11faec785303cfca3a5c3eb5f329ba7023"
@@ -27,7 +28,7 @@ PACKAGECONFIG[jack] = ",,jack"
PACKAGECONFIG[openal] = ",,openal-soft"
PACKAGECONFIG[portaudio] = ",,portaudio-v19"
PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
-PACKAGECONFIG[sdl] = ",,libsdl"
+PACKAGECONFIG[sdl] = ",,libsdl2"
# Following are possible sound output modules:
# alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi