aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorAndre McCurdy <armccurdy@gmail.com>2016-01-19 10:33:10 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:25 +0000
commit6752484affe84928ab83f2fbf90610c1f3f0a70f (patch)
tree1372b25a309ea9ae3e9f93e56091d2078cb7f559 /meta/recipes-multimedia
parentad8f20141f049cb68f974a678e956e35c17daa6d (diff)
downloadopenembedded-core-contrib-6752484affe84928ab83f2fbf90610c1f3f0a70f.tar.gz
gstreamer1.0-plugins-bad: update git recipe to 1.7.1
Handle renaming of the HLS plugin: http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=efe62292a3d045126654d93239fdf4cc8e48ae08 Switch AES decryption for the HLS plugin from nettle to openssl. The autogen.sh script takes care of cd'ing to the correct directory before it does anything, so we don't need to cd on its behalf any more in do_configure_prepend(). http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/tree/autogen.sh?id=1.7.1 (From OE-Core rev: e91f29fb360b022cb3eaba9c2b09c247677961d8) Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_git.bb40
1 files changed, 29 insertions, 11 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_git.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_git.bb
index 654eab062e..ebf579fad5 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_git.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_git.bb
@@ -7,21 +7,39 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
file://gst/tta/crc32.h;beginline=12;endline=29;md5=27db269c575d1e5317fffca2d33b3b50 \
file://gst/tta/filters.h;beginline=12;endline=29;md5=8a08270656f2f8ad7bb3655b83138e5a"
-SRC_URI = "git://anongit.freedesktop.org/gstreamer/gst-plugins-bad"
+SRC_URI = " \
+ git://anongit.freedesktop.org/gstreamer/gst-plugins-bad;name=base \
+ git://anongit.freedesktop.org/gstreamer/common;destsuffix=git/common;name=common \
+ file://configure-allow-to-disable-libssh2.patch \
+"
-SRCREV = "6e5db57d2446a753aaa76bee268e1f95600b14ce"
+PV = "1.7.1+git${SRCPV}"
-S = "${WORKDIR}/git"
+SRCREV_base = "3a088ecc9330d5cb8888ff43de0fe4f61c23a607"
+SRCREV_common = "86e46630ed8af8d94796859db550a9c3d89c9f65"
+SRCREV_FORMAT = "base"
-PACKAGECONFIG[sbc] = "--enable-sbc,--disable-sbc,sbc"
-PACKAGECONFIG[hls] = "--enable-hls,--disable-hls,gnutls"
+S = "${WORKDIR}/git"
-EXTRA_OECONF += " \
- -disable-openjpeg \
-"
+# over-ride the default hls PACKAGECONFIG in gstreamer1.0-plugins-bad.inc to
+# pass an additional --with-hls-crypto=XXX option (new in 1.7.x) and switch HLS
+# AES decryption from nettle to openssl (ie a shared dependency with dtls).
+# This should move back to the common .inc once the main recipe updates to 1.8.x
+PACKAGECONFIG[hls] = "--enable-hls --with-hls-crypto=openssl,--disable-hls,openssl"
do_configure_prepend() {
- cd ${S}
- ./autogen.sh --noconfigure
- cd ${B}
+ ${S}/autogen.sh --noconfigure
+}
+
+# In 1.6.2, the "--enable-hls" configure option generated an installable package
+# called "gstreamer1.0-plugins-bad-fragmented". In 1.7.1 that HLS plugin package
+# has become "gstreamer1.0-plugins-bad-hls". See:
+# http://cgit.freedesktop.org/gstreamer/gst-plugins-bad/commit/?id=efe62292a3d045126654d93239fdf4cc8e48ae08
+
+PACKAGESPLITFUNCS_append = " handle_hls_rename "
+
+python handle_hls_rename () {
+ d.setVar('RPROVIDES_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
+ d.setVar('RREPLACES_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
+ d.setVar('RCONFLICTS_gstreamer1.0-plugins-bad-hls', 'gstreamer1.0-plugins-bad-fragmented')
}