summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2017-08-11 23:36:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 00:01:40 +0100
commita6c12ff35c97f4225a6b2f226ae4483d7bacdfb9 (patch)
tree016fd384b80b32a46077022fed5f1c0b24055bf0 /meta/recipes-multimedia
parent89dfede4ca795ba085f1ee7290c6dede573c11db (diff)
downloadopenembedded-core-contrib-a6c12ff35c97f4225a6b2f226ae4483d7bacdfb9.tar.gz
gstreamer1.0: upgrade to version 1.12.2
* Version 1.12 introduces support for libdw (provided by elfutils). libdw adds source lines & numbers to backtraces. A new "dw" packageconfig added for enabling/disabling this feature. In addition, the old patch for deterministic unwind configuration was replaced with one that also allows the same for the dw configuration. This new patch was also submitted to bugzilla. * Leftover docbook cruft was removed, meaning that the "--disable-docbook" configure switch is gone. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-multimedia')
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0.inc2
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0/0001-configure-Add-switches-for-enabling-disabling-libdw-.patch70
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0/deterministic-unwind.patch24
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.12.2.bb (renamed from meta/recipes-multimedia/gstreamer/gstreamer1.0_1.10.4.bb)6
4 files changed, 74 insertions, 28 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0.inc b/meta/recipes-multimedia/gstreamer/gstreamer1.0.inc
index 72d7ce68d0..329193486d 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0.inc
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0.inc
@@ -25,10 +25,10 @@ PACKAGECONFIG[tests] = "--enable-tests,--disable-tests"
PACKAGECONFIG[valgrind] = "--enable-valgrind,--disable-valgrind,valgrind,"
PACKAGECONFIG[gst-tracer-hooks] = "--enable-gst-tracer-hooks,--disable-gst-tracer-hooks,"
PACKAGECONFIG[unwind] = "--with-unwind,--without-unwind,libunwind"
+PACKAGECONFIG[dw] = "--with-dw,--without-dw,elfutils"
EXTRA_OECONF = " \
--disable-dependency-tracking \
- --disable-docbook \
--disable-examples \
"
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0/0001-configure-Add-switches-for-enabling-disabling-libdw-.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0/0001-configure-Add-switches-for-enabling-disabling-libdw-.patch
new file mode 100644
index 0000000000..1132fd5a48
--- /dev/null
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0/0001-configure-Add-switches-for-enabling-disabling-libdw-.patch
@@ -0,0 +1,70 @@
+From a0cb41ba72913eda06049d266ec43ea8f52b5bee Mon Sep 17 00:00:00 2001
+From: Carlos Rafael Giani <dv@pseudoterminal.org>
+Date: Fri, 11 Aug 2017 21:21:36 +0200
+Subject: [PATCH] configure: Add switches for enabling/disabling libdw and
+ libunwind
+
+[Original patch modified to be applicable to 1.12.2]
+
+Upstream-Status: Submitted [https://bugzilla.gnome.org/show_bug.cgi?id=778193]
+
+Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
+---
+ configure.ac | 38 ++++++++++++++++++++++++++++++++------
+ 1 file changed, 32 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b6b2923..32dd827 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -821,15 +821,41 @@ fi
+ AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
+
+ dnl libunwind is optionally used by the leaks tracer
+-PKG_CHECK_MODULES(UNWIND, libunwind, HAVE_UNWIND=yes, HAVE_UNWIND=no)
+-if test "x$HAVE_UNWIND" = "xyes"; then
+- AC_DEFINE(HAVE_UNWIND, 1, [libunwind available])
++AC_ARG_WITH([unwind],[AS_HELP_STRING([--with-unwind=yes|no|auto],[use libunwind])],
++ [], [with_unwind=auto])
++if [ test "x${with_unwind}" != "xno" ]; then
++ PKG_CHECK_MODULES(UNWIND, [libunwind],
++ [
++ HAVE_UNWIND=yes
++ AC_DEFINE(HAVE_UNWIND, 1, [libunwind available])
++ ],
++ [
++ HAVE_UNWIND=no
++ if [ test "x${with_unwind}" = "xyes" ]; then
++ AC_MSG_ERROR([could not find libunwind])
++ fi
++ ])
++else
++ HAVE_UNWIND=no
+ fi
+
+ dnl libdw is optionally used to add source lines and numbers to backtraces
+-PKG_CHECK_MODULES(DW, libdw, HAVE_DW=yes, HAVE_DW=no)
+-if test "x$HAVE_DW" = "xyes"; then
+- AC_DEFINE(HAVE_DW, 1, [libdw available])
++AC_ARG_WITH([dw],[AS_HELP_STRING([--with-dw=yes|no|auto],[use libdw])],
++ [], [with_dw=auto])
++if [ test "x${with_dw}" != "xno" ]; then
++ PKG_CHECK_MODULES(DW, [libdw],
++ [
++ HAVE_DW=yes
++ AC_DEFINE(HAVE_DW, 1, [libdw available])
++ ],
++ [
++ HAVE_DW=no
++ if [ test "x${with_dw}" = "xyes" ]; then
++ AC_MSG_ERROR([could not find libdw])
++ fi
++ ])
++else
++ HAVE_DW=no
+ fi
+
+ dnl Check for backtrace() from libc
+--
+2.7.4
+
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0/deterministic-unwind.patch b/meta/recipes-multimedia/gstreamer/gstreamer1.0/deterministic-unwind.patch
deleted file mode 100644
index e39e6cad09..0000000000
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0/deterministic-unwind.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Make the detection of libunwind deterministic.
-
-Upstream-Status: Pending
-Signed-off-by: Ross Burton <ross.burton@intel.com>
-
-diff --git a/configure.ac b/configure.ac
-index ac88fb2..182c19a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -829,3 +828,0 @@ AM_CONDITIONAL(HAVE_GTK, test "x$HAVE_GTK" = "xyes")
--dnl libunwind is optionally used by the leaks tracer
--PKG_CHECK_MODULES(UNWIND, libunwind, HAVE_UNWIND=yes, HAVE_UNWIND=no)
--
-@@ -839,3 +836,7 @@ AC_CHECK_FUNC(backtrace, [
--if test "x$HAVE_UNWIND" = "xyes"; then
-- AC_DEFINE(HAVE_UNWIND, 1, [libunwind available])
--fi
-+dnl libunwind is optionally used by the leaks tracer
-+AC_ARG_WITH([unwind],[AS_HELP_STRING([--with-unwind],[use libunwind])],
-+ [], [with_unwind=yes])
-+AS_IF([test "$with_unwind" = yes],
-+ [PKG_CHECK_MODULES(UNWIND, libunwind)
-+ AC_DEFINE(HAVE_UNWIND, 1, [libunwind available])]
-+)
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.10.4.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.12.2.bb
index 2a6799345f..8d41a59d91 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.10.4.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.12.2.bb
@@ -5,9 +5,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \
SRC_URI = " \
http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \
- file://deterministic-unwind.patch \
+ file://0001-configure-Add-switches-for-enabling-disabling-libdw-.patch \
"
-SRC_URI[md5sum] = "7c91a97e4a2dc81eafd59d0a2f8b0d6e"
-SRC_URI[sha256sum] = "50c2f5af50a6cc6c0a3f3ed43bdd8b5e2bff00bacfb766d4be139ec06d8b5218"
+SRC_URI[md5sum] = "4748860621607ffd96244fb79c86c238"
+SRC_URI[sha256sum] = "9fde3f39a2ea984f9e07ce09250285ce91f6e3619d186889f75b5154ecf994ba"
S = "${WORKDIR}/gstreamer-${PV}"