aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt/qt-apps/qmmp_0.6.6.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-02-05 15:55:46 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-02-06 09:35:01 +0000
commit12484dca3bf09dd9a03442a223885deb7472a6cd (patch)
tree398ad1f9a2845d07f3da8354b1919ff0ad1788c1 /meta/recipes-qt/qt-apps/qmmp_0.6.6.bb
parent871549996cfcaf860083d867eb6a9522f4407cd4 (diff)
downloadopenembedded-core-contrib-12484dca3bf09dd9a03442a223885deb7472a6cd.tar.gz
qmmp: update to 0.6.6 and fix
* Update to 0.6.6 * Fix compilation failure due to unconditional call to QApplication::commitData() * Disable /usr/local host paths to avoid compilation warnings * Force use of the cmake configure instead of qmake as the latter is not dynamic with Qmmp and doesn't let you disable certain dependencies (e.g. enca) * Add libsndfile1, libsamplerate0 and curl to DEPENDS since their use will be non-deterministic otherwise * Explicitly disable library-requiring options that we don't have available in OE-Core so that they don't get used if they happen to be in the sysroot * Update LIC_FILES_CHKSUM since there were cosmetic changes to the license file (mostly reformatting and change of references to LGPL from "Library" to "Lesser".) Fixes [YOCTO #3822]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-qt/qt-apps/qmmp_0.6.6.bb')
-rw-r--r--meta/recipes-qt/qt-apps/qmmp_0.6.6.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-qt/qt-apps/qmmp_0.6.6.bb b/meta/recipes-qt/qt-apps/qmmp_0.6.6.bb
new file mode 100644
index 0000000000..2f5e0d5830
--- /dev/null
+++ b/meta/recipes-qt/qt-apps/qmmp_0.6.6.bb
@@ -0,0 +1,76 @@
+DESCRIPTION = "Qmmp (Qt-based Multimedia Player) is an audio-player, written with help of Qt library"
+HOMEPAGE = "http://qmmp.ylsoftware.com"
+LICENSE = "GPLv2"
+LICENSE_FLAGS = "commercial"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+SECTION = "multimedia"
+
+DEPENDS = "taglib libmad libvorbis libogg alsa-lib libsndfile1 libsamplerate0 curl"
+
+SRC_URI = "http://qmmp.ylsoftware.com/files/${BPN}-${PV}.tar.bz2 \
+ file://no-host-paths.patch \
+ file://no-sessionmanager.patch"
+
+SRC_URI[md5sum] = "0131a9bf7b98737c1a6fd6e1a897e2b2"
+SRC_URI[sha256sum] = "dfa973cca80c020a85a11bb66701a3804f9fde326440abb179559c98bf3b5b99"
+
+inherit cmake qt4x11
+
+QMMP_PLUGIN_OPTIONS ??= "\
+ -DUSE_MMS:BOOL=FALSE \
+ -DUSE_MPC:BOOL=FALSE \
+ -DUSE_MODPLUG:BOOL=FALSE \
+ -DUSE_WAVPACK:BOOL=FALSE \
+ -DUSE_FFMPEG:BOOL=FALSE \
+ -DUSE_AAC:BOOL=FALSE \
+ -DUSE_CDA:BOOL=FALSE \
+ -DUSE_MIDI:BOOL=FALSE \
+ -DUSE_GME:BOOL=FALSE \
+ -DUSE_OSS4:BOOL=FALSE \
+ -DUSE_JACK:BOOL=FALSE \
+ -DUSE_BS2B:BOOL=FALSE \
+ -DUSE_PROJECTM:BOOL=FALSE \
+ -DUSE_ENCA:BOOL=FALSE \
+ "
+
+export EXTRA_OECMAKE = "-DQT_QMAKE_EXECUTABLE=${OE_QMAKE_QMAKE} \
+ -DQT_LRELEASE_EXECUTABLE=${OE_QMAKE_LRELEASE} \
+ -DQT_MOC_EXECUTABLE=${OE_QMAKE_MOC} \
+ -DQT_UIC_EXECUTABLE=${OE_QMAKE_UIC} \
+ -DQT_RCC_EXECUTABLE=${OE_QMAKE_RCC} \
+ -DQT_LIBRARY_DIR=${OE_QMAKE_LIBDIR_QT} \
+ -DQT_HEADERS_DIR=${OE_QMAKE_INCDIR_QT} \
+ -DQT_QTCORE_INCLUDE_DIR=${OE_QMAKE_INCDIR_QT}/QtCore \
+ ${QMMP_PLUGIN_OPTIONS} \
+ "
+
+do_configure() {
+ # Ensure we get the cmake configure and not qmake
+ cmake_do_configure
+}
+
+PACKAGES_DYNAMIC += "^qmmp-plugin-.* "
+
+python populate_packages_prepend () {
+ qmmp_libdir = d.expand('${libdir}/qmmp')
+ gd = d.expand('${D}/${libdir}/qmmp')
+ plug_dirs = os.listdir(gd)
+
+ for plug_dir in plug_dirs:
+ g_plug_dir = os.path.join(qmmp_libdir,plug_dir)
+ do_split_packages(d, g_plug_dir, '^lib(.*)\.so$', 'qmmp-plugin-' + plug_dir.lower() + '-%s', 'Qmmp' + plug_dir + 'plugin for %s')
+}
+
+FILES_${PN} = "\
+ ${bindir}/qmmp \
+ ${libdir}/lib*${SOLIBS} \
+ ${datadir}/icons/* \
+ ${datadir}/qmmp/images/* \
+ ${datadir}/applications/* \
+ "
+
+FILES_${PN}-dbg += "\
+ ${libdir}/qmmp/*/.debug/* \
+ "
+
+RDEPENDS_${PN} += "taglib alsa-lib libmad curl"