summaryrefslogtreecommitdiffstats
path: root/meta/recipes-rt
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-07-25 21:03:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-07-26 08:56:07 +0100
commit2230e5f7bf7e6dc747ada74477d5a72905d8d80b (patch)
tree793cade99a0cfe2f66ec68e8441d80a2f8c29116 /meta/recipes-rt
parent4b7d1bf8172533e9ac91a49ade152a05e2ee4146 (diff)
downloadopenembedded-core-contrib-2230e5f7bf7e6dc747ada74477d5a72905d8d80b.tar.gz
rt-tests: rationalise compiler flags
This recipe uses some convoluted methods to ensure the build is using the right flags but they don't appear to be needed anymore. No need to prepend HOST_CC_ARCH/TOOLCHAIN_OPTIONS via CFLAGS as the Makefile picks up CC from the environment and that includes these options. No need to append the default CFLAGS as their special options are actually in CPPFLAGS. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-rt')
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests.inc3
-rw-r--r--meta/recipes-rt/rt-tests/rt-tests_2.0.bb4
2 files changed, 1 insertions, 6 deletions
diff --git a/meta/recipes-rt/rt-tests/rt-tests.inc b/meta/recipes-rt/rt-tests/rt-tests.inc
index fd6500bfad..d832828e97 100644
--- a/meta/recipes-rt/rt-tests/rt-tests.inc
+++ b/meta/recipes-rt/rt-tests/rt-tests.inc
@@ -5,8 +5,5 @@ SRC_URI = "git://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git"
S = "${WORKDIR}/git"
-# need to append rt-tests' default CFLAGS to ours
-CFLAGS += "-I${S}/src/include -D_GNU_SOURCE -Wall -Wno-nonnull"
-
# calling 'uname -m' is broken on crossbuilds
EXTRA_OEMAKE = "NUMA=0"
diff --git a/meta/recipes-rt/rt-tests/rt-tests_2.0.bb b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
index 83869b89b8..4336c50d63 100644
--- a/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
+++ b/meta/recipes-rt/rt-tests/rt-tests_2.0.bb
@@ -15,9 +15,7 @@ SRC_URI += " \
file://rt_bmark.py \
"
# Do not install hwlatdetect
-EXTRA_OEMAKE += "PYLIB='' CROSS_COMPILE=${TARGET_PREFIX}"
-
-CFLAGS_prepend = "${HOST_CC_ARCH}${TOOLCHAIN_OPTIONS}"
+EXTRA_OEMAKE += "PYLIB=''"
do_install() {
oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \