summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-14 12:34:11 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-23 11:43:40 +0100
commit8808d4b13a946499bc6e84a1be15f53d8ab3f673 (patch)
tree22d5be172e25145d14fd1f2d9e48c943d3592955 /meta/recipes-sato
parent07f4b0f016225e2b211689a270e56b2923ecb434 (diff)
downloadopenembedded-core-contrib-8808d4b13a946499bc6e84a1be15f53d8ab3f673.tar.gz
webkitgtk: Upgrade to 2.16.3
Use bfd linker on ppc, this is because gold fails to link webkit libraries when PIE is enabled Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk/ppc-musl-fix.patch12
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.16.3.bb (renamed from meta/recipes-sato/webkit/webkitgtk_2.16.1.bb)5
2 files changed, 9 insertions, 8 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk/ppc-musl-fix.patch b/meta/recipes-sato/webkit/webkitgtk/ppc-musl-fix.patch
index 5f58e4953e..a1ad248aac 100644
--- a/meta/recipes-sato/webkit/webkitgtk/ppc-musl-fix.patch
+++ b/meta/recipes-sato/webkit/webkitgtk/ppc-musl-fix.patch
@@ -11,16 +11,16 @@ Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Index: webkitgtk-2.12.3/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+Index: webkitgtk-2.16.3/Source/JavaScriptCore/heap/MachineStackMarker.cpp
===================================================================
---- webkitgtk-2.12.3.orig/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-+++ webkitgtk-2.12.3/Source/JavaScriptCore/heap/MachineStackMarker.cpp
-@@ -86,7 +86,7 @@ static void pthreadSignalHandlerSuspendR
+--- webkitgtk-2.16.3.orig/Source/JavaScriptCore/heap/MachineStackMarker.cpp
++++ webkitgtk-2.16.3/Source/JavaScriptCore/heap/MachineStackMarker.cpp
+@@ -88,7 +88,7 @@ static void pthreadSignalHandlerSuspendR
}
ucontext_t* userContext = static_cast<ucontext_t*>(ucontext);
-#if CPU(PPC)
+#if CPU(PPC) && defined(__GLIBC__)
- thread->suspendedMachineContext = *userContext->uc_mcontext.uc_regs;
+ threadData->suspendedMachineContext = *userContext->uc_mcontext.uc_regs;
#else
- thread->suspendedMachineContext = userContext->uc_mcontext;
+ threadData->suspendedMachineContext = userContext->uc_mcontext;
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.16.1.bb b/meta/recipes-sato/webkit/webkitgtk_2.16.3.bb
index a52d93cfbe..5feca17be3 100644
--- a/meta/recipes-sato/webkit/webkitgtk_2.16.1.bb
+++ b/meta/recipes-sato/webkit/webkitgtk_2.16.3.bb
@@ -22,8 +22,8 @@ SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
file://gcc7.patch \
file://detect-atomics-during-configure.patch \
"
-SRC_URI[md5sum] = "d3bcf995a667fd9febb9ab991acf0ca7"
-SRC_URI[sha256sum] = "eb92383232328ce655b703c64370ed3795662479719ad1b4a869ed46769d2945"
+SRC_URI[md5sum] = "34dbbcad8a87a929519d93c67edd6d87"
+SRC_URI[sha256sum] = "204e9131da0101b9bc8765716e70a897121af04b964d9827cd9f20816a77b512"
inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc
@@ -76,6 +76,7 @@ EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
# https://sourceware.org/bugzilla/show_bug.cgi?id=18430
EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF "
EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
+EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
EXTRA_OECMAKE_append_toolchain-clang = " -DUSE_LD_GOLD=OFF "
EXTRA_OECMAKE_append_aarch64 = " -DWTF_CPU_ARM64_CORTEXA53=ON"