summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-05-19 20:40:57 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-20 21:40:14 +0100
commite14f9f31d24c517e59f250cb79a536ed4b01bc5d (patch)
tree55cbf570b6d4e33c17dd9f6f6453bfaaaa655b5a /meta/recipes-sato
parentbcbfc531b68799cf206277d13322a093879e17ae (diff)
downloadopenembedded-core-contrib-e14f9f31d24c517e59f250cb79a536ed4b01bc5d.tar.gz
midori: fix build with GLib 2.44
GLib 2.44 introduced a GListStore type which is ambiguous with GtkListStore when using wildcard using statements. Use the full type name to fix builds. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-sato')
-rw-r--r--meta/recipes-sato/midori/midori/liststore.patch29
-rw-r--r--meta/recipes-sato/midori/midori_0.5.8.bb4
2 files changed, 32 insertions, 1 deletions
diff --git a/meta/recipes-sato/midori/midori/liststore.patch b/meta/recipes-sato/midori/midori/liststore.patch
new file mode 100644
index 0000000000..4e5d666afd
--- /dev/null
+++ b/meta/recipes-sato/midori/midori/liststore.patch
@@ -0,0 +1,29 @@
+GLib 2.44 has a GListStore type which is GLib.ListStore in Vala, resulting in an ambigous type and compile failure.
+
+Fix by using the full type name.
+
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+diff --git a/extensions/history-list.vala b/extensions/history-list.vala
+index 3a864b1..f309c0c 100644
+--- a/extensions/history-list.vala
++++ b/extensions/history-list.vala
+@@ -319,7 +319,7 @@ namespace HistoryList {
+ }
+
+ private void create_widgets () {
+- ListStore model;
++ Gtk.ListStore model;
+ TreeIter iter;
+ TreeIter? active_iter = null;
+
+@@ -331,7 +331,7 @@ namespace HistoryList {
+
+ var tab_closing_behavior = this.hl_manager.get_integer ("TabClosingBehavior");
+
+- model = new ListStore (2, typeof (string), typeof (int));
++ model = new Gtk.ListStore (2, typeof (string), typeof (int));
+
+ model.append (out iter);
+ model.set (iter, TabClosingBehaviorModel.TEXT, _("Do nothing"),
diff --git a/meta/recipes-sato/midori/midori_0.5.8.bb b/meta/recipes-sato/midori/midori_0.5.8.bb
index 5cc42cbc50..aa1b395b84 100644
--- a/meta/recipes-sato/midori/midori_0.5.8.bb
+++ b/meta/recipes-sato/midori/midori_0.5.8.bb
@@ -4,7 +4,9 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
DEPENDS = "webkit-gtk libsoup-2.4 openssl python-native python-docutils-native librsvg-native libnotify libxscrnsaver"
-SRC_URI = "https://launchpad.net/midori/trunk/0.5.8/+download/${BPN}-${PV}.tar.bz2;subdir=${BPN}-${PV}"
+SRC_URI = "https://launchpad.net/midori/trunk/0.5.8/+download/${BPN}-${PV}.tar.bz2;subdir=${BPN}-${PV} \
+ file://liststore.patch"
+
SRC_URI[md5sum] = "b89e25e74199d705e74767499a415976"
SRC_URI[sha256sum] = "af19135fd4c4b04345df4d3592e7939c20f9b40eaca24550e6cb619751aa9381"