aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2012-03-23 17:56:29 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-06 01:07:14 +0100
commite4d2ee00419f675ba8b7fb5d75256762253d8b32 (patch)
treeed0a3cde9491a509683143dbccf1e97044c75697 /meta/recipes-support/gdbm
parent3e4562500956550dbae5467a5fe9289f1d32f775 (diff)
downloadopenembedded-core-contrib-e4d2ee00419f675ba8b7fb5d75256762253d8b32.tar.gz
gdbm: Activate -enable-libgdbm-compat and add symlinks to headers in include/gdbm
ndbm.h is needed by python for dbm module. This is why -enable-libgdbm-compat was added to configure. The second change is because python is looking for the gdbm headers in include/gdbm. The easiest way to solve this issue is to add symlinks in include/gdbm. [YOCTO #1937] Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
Diffstat (limited to 'meta/recipes-support/gdbm')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.10.bb13
1 files changed, 12 insertions, 1 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.10.bb b/meta/recipes-support/gdbm/gdbm_1.10.bb
index 9b2fde4539..26b80093e7 100644
--- a/meta/recipes-support/gdbm/gdbm_1.10.bb
+++ b/meta/recipes-support/gdbm/gdbm_1.10.bb
@@ -4,7 +4,7 @@ SECTION = "libs"
LICENSE = "GPLv3"
LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
-PR = "r1"
+PR = "r2"
SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz"
@@ -13,4 +13,15 @@ SRC_URI[sha256sum] = "23f8134c5b94bbfb06d756a6b78f074fba6e6028cf2fe01341d40b26db
inherit autotools gettext lib_package
+# Needed for dbm python module
+EXTRA_OECONF = "-enable-libgdbm-compat"
+
BBCLASSEXTEND = "native nativesdk"
+
+do_install_append () {
+ # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
+ # these headers
+ install -d ${D}${includedir}/gdbm
+ ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
+ ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
+}