aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-13 19:40:52 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-24 09:40:31 +0000
commit67eef116d5810d171b9d5c63669671cc73eaeb8b (patch)
treeedea521efedc15d5abbeff63dbb0d1b8761f8db0 /meta/recipes-support/gpgme
parent368e838f7764b6842b56555a88713fdd9596f809 (diff)
downloadopenembedded-core-contrib-67eef116d5810d171b9d5c63669671cc73eaeb8b.tar.gz
gpgme: Define __error_t_defined on musl
Configure looks for error_t in errno.h and musl does not define error_t if its not defined then configure emits a definition to be used, now we also use standalone argp implementation from glibc on musl based systems which defines this in argp.h as well so now we have it defined twice and errors like | /a/builder/mnt/build-oe/tmp-musl/sysroots/raspberrypi2/usr/include/argp.h:40:13: error: cannot combine with previous 'int' declaration specifier | typedef int error_t; | ^ | ../config.h:257:17: note: expanded from macro 'error_t' | #define error_t int | ^ | 1 error generated. are seen. argp.h definition is conditional on __error_t_defined which is true here so lets define it on musl (From OE-Core rev: 29e1edcba39a21057ba5862eef4e79c177e7ef62) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gpgme')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.6.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.6.0.bb b/meta/recipes-support/gpgme/gpgme_1.6.0.bb
index 987d19bc4e..86eda239bf 100644
--- a/meta/recipes-support/gpgme/gpgme_1.6.0.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.6.0.bb
@@ -27,6 +27,7 @@ PACKAGES =+ "${PN}-pthread"
FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
+CFLAGS_append_libc-musl = " -D__error_t_defined "
do_configure_prepend () {
# Else these could be used in preference to those in aclocal-copy
rm -f ${S}/m4/gpg-error.m4