aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu
diff options
context:
space:
mode:
authorAndré Draszik <adraszik@digisoft.tv>2015-05-18 09:06:01 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-20 21:41:07 +0100
commit336ddb3109e321bd83b902f1c0573f7b106718a8 (patch)
tree79ed887ea6d193b6e0a9cdfd1785107aa79d7646 /meta/recipes-support/icu
parentd642865f1bbbc5a973ccb537dea5459c84eef97b (diff)
downloadopenembedded-core-contrib-336ddb3109e321bd83b902f1c0573f7b106718a8.tar.gz
icu-native: fix hard paths in native icu
The icu recipe installs icu-native twice, once in the usual location, and once for cross builds into the path given by --with-cross-build. This latter path is not included in the list of paths recognised by chrpath.bbclass, hence the binaries in there retain the rpath as used during compilation. This causes the package to not be relocateable from sstate [YOCTO #6851] We use the infrastructure that is in place already, and simply set PREPROCESS_RELOCATE_DIRS as necessary, and things start to work. (From OE-Core rev: e7fcaa534511e3f65b630b01cf0c824ee5a5fd4d) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/icu')
-rw-r--r--meta/recipes-support/icu/icu.inc1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-support/icu/icu.inc b/meta/recipes-support/icu/icu.inc
index f4254b5f5c..cc6f222a50 100644
--- a/meta/recipes-support/icu/icu.inc
+++ b/meta/recipes-support/icu/icu.inc
@@ -26,6 +26,7 @@ EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
EXTRA_OECONF_class-native = ""
EXTRA_OECONF_class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
+PREPROCESS_RELOCATE_DIRS = "${datadir}/${BPN}/${PV}"
do_install_append_class-native() {
mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config