aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.0.2.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2017-04-10 12:15:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-04-11 18:09:21 +0100
commit210c518ba8f8d6ec6e9d34e0df8b963a3b2e0593 (patch)
tree4ee2fb32a72f6feab67d3be0cde3c0d7f81bfc1f /meta/recipes-support/ptest-runner/ptest-runner_2.0.2.bb
parentef94ffee8f11db57ecea398af76dc22576c2068a (diff)
downloadopenembedded-core-contrib-210c518ba8f8d6ec6e9d34e0df8b963a3b2e0593.tar.gz
ptest-runner: Upgrade to minor version 2.0.2
To fix a problem when print ERROR after a ptest timeout, this causes the user confusion about if a test ends or not. [YOCTO #10842] Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.0.2.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.0.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.0.2.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.0.2.bb
new file mode 100644
index 0000000000..a3e9a7e214
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.0.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A C program to run all installed ptests"
+DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
+program which loops through all installed ptest test suites and \
+runs them in sequence."
+HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+SRCREV = "6d2872116cd9d6e1617a768f9d72bbf091489b2d"
+PV = "2.0.2+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
+S = "${WORKDIR}/git"
+
+FILES_${PN} = "${bindir}/ptest-runner"
+
+EXTRA_OEMAKE = "-e MAKEFLAGS="
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
+}