aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2014-12-08 01:08:03 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-12-11 11:26:08 +0000
commit475709fc4f32e1ed01f45ee44819cd24e739eb43 (patch)
treed8738603cd356bd1473a478fc9b67490e6f91d52 /meta/recipes-support
parent39bb9f47c727c5518a794aac976dacd4b00a0534 (diff)
downloadopenembedded-core-contrib-475709fc4f32e1ed01f45ee44819cd24e739eb43.tar.gz
apr: avoid absolute paths for grep
The apr provides usr/share/build-1/libtool which is required by the recipe such as apache2, and it will find grep on the host and set absolute paths in libtool: GREP="/usr/bin/grep" If we build apr/apr-native on a host that grep is in "/usr/bin/grep", and re-use the sstate on another host with "/bin/grep", it will fail when build apache2/apache2-native with: | tmp/sysroots/x86_64-linux/usr/share/build-1/libtool: line 1093: /usr/bin/grep: No such file or directory | tmp/sysroots/intel-x86-64/usr/share/build-1/libtool: line 1093: /usr/bin/grep: No such file or directory Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/apr/apr_1.5.1.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr_1.5.1.bb b/meta/recipes-support/apr/apr_1.5.1.bb
index 49a08b0261..a27b2338d1 100644
--- a/meta/recipes-support/apr/apr_1.5.1.bb
+++ b/meta/recipes-support/apr/apr_1.5.1.bb
@@ -32,6 +32,11 @@ CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
do_configure_prepend() {
+ # Avoid absolute paths for grep since it causes failures
+ # when using sstate between different hosts with different
+ # install paths for grep.
+ export GREP="grep"
+
cd ${S}
./buildconf
}