aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-04-11 18:31:38 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-04-23 11:41:03 +0100
commit53af71200b6f6d117e1e7dc2e7a7d21c6faab8f9 (patch)
tree862b3c41f4ff203d8bab7710dfd8fa94a7c0a593 /meta/recipes-support
parentbec37f8b85b6dd1e4e1c1b9b215a7952ca2fc386 (diff)
downloadopenembedded-core-contrib-53af71200b6f6d117e1e7dc2e7a7d21c6faab8f9.tar.gz
apr: remove the use of ${SHELL} to avoid bash/dash confliction
While multible hosts sharing a common sstate cache, the fist host using bash as default shell and build apr, the second host using dash as default shell and build apr-util, there was a failure in apr-util: ... | /bin/sh: 0: Can't open i586-poky-linux-libtool | make[1]: *** [dbm/apr_dbm_gdbm.lo] Error 127 | make[1]: *** Waiting for unfinished jobs.... | make[1]: Leaving directory `tmp/work/i586-poky-linux/apr-util/1.5.2-r0/apr-util-1.5.2' ... The quick way to reproduce the defect in Ubuntu 1204: 1. Create a new build 2. sudo dpkg-reconfigure dash <set bash as /bin/sh> 3. bitbake apr 4. sudo dpkg-reconfigure dash <set dash as /bin/sh> 5. bitbake apr-util Remove the use of $(SHELL) in the apr could avoid this issue. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/apr/apr_1.4.8.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/apr/apr_1.4.8.bb b/meta/recipes-support/apr/apr_1.4.8.bb
index 4d36585a3e..7a130d1bdc 100644
--- a/meta/recipes-support/apr/apr_1.4.8.bb
+++ b/meta/recipes-support/apr/apr_1.4.8.bb
@@ -56,7 +56,7 @@ apr_sysroot_preprocess () {
cp ${S}/build/apr_rules.mk $d/
sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
- sed -i s,LIBTOOL=.*,LIBTOOL=\$\(SHELL\)\ ${HOST_SYS}-libtool,g $d/apr_rules.mk
+ sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk
sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
cp ${S}/build/mkdir.sh $d/
cp ${S}/build/make_exports.awk $d/