summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-03 14:37:24 +0100
committerSteve Sakoman <steve@sakoman.com>2020-12-11 06:16:48 -1000
commit2d44aee1424d50949a8f38bc5b020d93804d5279 (patch)
tree3bab63f7634caefdb9bd03582d6247d8df47ba09 /meta/recipes-support
parent359f8e8bf9979aafedeafc3d012c6005ffcf3174 (diff)
downloadopenembedded-core-contrib-2d44aee1424d50949a8f38bc5b020d93804d5279.tar.gz
serf: do not install the static library
scons is using host ar to create it, which may or may not be built with reproducible option by default. Rather than patch scons for the benefit of a single recipe, let's just not install the .a, which is unused anyway. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 7e44275f4d286f005b2f19e3dcc9c6d390b98f30) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/serf/serf_1.3.9.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/serf/serf_1.3.9.bb b/meta/recipes-support/serf/serf_1.3.9.bb
index 6a27f12102..2fbf96f997 100644
--- a/meta/recipes-support/serf/serf_1.3.9.bb
+++ b/meta/recipes-support/serf/serf_1.3.9.bb
@@ -30,4 +30,9 @@ EXTRA_OESCONS = " \
OPENSSL="${STAGING_EXECPREFIXDIR}" \
"
+# scons creates non-reproducible archives
+do_install_append() {
+ rm ${D}/${libdir}/*.a
+}
+
BBCLASSEXTEND = "native nativesdk"