summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2015-12-01 17:55:50 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-08 10:20:07 +0000
commit9950c08341a2950521f18a1bf4593e84dfab864b (patch)
tree92fac4107e4ba4cfd4118e726f6b3fee0f7f07a2 /meta/recipes-support
parent7352107cafd59ec051f2d6cedc0a61c5c38fa943 (diff)
downloadopenembedded-core-contrib-9950c08341a2950521f18a1bf4593e84dfab864b.tar.gz
libbsd: Upgrade to 0.8.0
Upgrade the library version to recently released 0.8.0 . The COPYING file changed again, but the changes are just new names added to the Copyright (C) YYYY John Doe <...> section, no changes to the license itself. Signed-off-by: Marek Vasut <marex@denx.de> Cc: Khem Raj <raj.khem@gmail.com> Cc: Saul Wold <sgw@linux.intel.com> Cc: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libbsd/libbsd/0001-Use-local-SHA512-header.patch75
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.8.0.bb (renamed from meta/recipes-support/libbsd/libbsd_0.7.0.bb)11
2 files changed, 82 insertions, 4 deletions
diff --git a/meta/recipes-support/libbsd/libbsd/0001-Use-local-SHA512-header.patch b/meta/recipes-support/libbsd/libbsd/0001-Use-local-SHA512-header.patch
new file mode 100644
index 0000000000..af47b2baba
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd/0001-Use-local-SHA512-header.patch
@@ -0,0 +1,75 @@
+From 8493c7f27da2dcd2de71e9c7782c3d020d89c2a2 Mon Sep 17 00:00:00 2001
+From: Guillem Jover <guillem@hadrons.org>
+Date: Tue, 1 Dec 2015 03:39:10 +0100
+Subject: [PATCH] Use local SHA512 header
+
+Actually use the local private SHA512 header instead of relying on the
+OpenSSL one for no good reason. Add definition for expected macro
+SHA512_DIGEST_LENGTH.
+
+Signed-off-by: Marek Vasut <marex@denx.de>
+Upstream-Status: Backport
+---
+ src/getentropy_aix.c | 2 +-
+ src/getentropy_hpux.c | 3 ++-
+ src/getentropy_linux.c | 3 ++-
+ src/hash/sha512.h | 2 ++
+ 4 files changed, 7 insertions(+), 3 deletions(-)
+
+diff --git a/src/getentropy_aix.c b/src/getentropy_aix.c
+index cbd4037..d4ccab7 100644
+--- a/src/getentropy_aix.c
++++ b/src/getentropy_aix.c
+@@ -39,7 +39,7 @@
+ #include <string.h>
+ #include <termios.h>
+
+-#include <openssl/sha.h>
++#include "hash/sha512.h"
+
+ #include <libperfstat.h>
+
+diff --git a/src/getentropy_hpux.c b/src/getentropy_hpux.c
+index 45ac84b..294d83a 100644
+--- a/src/getentropy_hpux.c
++++ b/src/getentropy_hpux.c
+@@ -41,7 +41,8 @@
+ #include <errno.h>
+ #include <unistd.h>
+ #include <time.h>
+-#include <openssl/sha.h>
++
++#include "hash/sha512.h"
+
+ #include <sys/vfs.h>
+
+diff --git a/src/getentropy_linux.c b/src/getentropy_linux.c
+index 0a5d6b8..d7a8ae5 100644
+--- a/src/getentropy_linux.c
++++ b/src/getentropy_linux.c
+@@ -47,7 +47,8 @@
+ #include <errno.h>
+ #include <unistd.h>
+ #include <time.h>
+-#include <openssl/sha.h>
++
++#include "hash/sha512.h"
+
+ #include <linux/types.h>
+ #include <linux/random.h>
+diff --git a/src/hash/sha512.h b/src/hash/sha512.h
+index 43c5aaf..4f368a1 100644
+--- a/src/hash/sha512.h
++++ b/src/hash/sha512.h
+@@ -31,6 +31,8 @@
+
+ #include <sys/types.h>
+
++#define SHA512_DIGEST_LENGTH 64
++
+ typedef struct SHA512Context {
+ uint64_t state[8];
+ uint64_t count[2];
+--
+2.6.2
+
diff --git a/meta/recipes-support/libbsd/libbsd_0.7.0.bb b/meta/recipes-support/libbsd/libbsd_0.8.0.bb
index 902666da7f..34569681da 100644
--- a/meta/recipes-support/libbsd/libbsd_0.7.0.bb
+++ b/meta/recipes-support/libbsd/libbsd_0.8.0.bb
@@ -9,13 +9,16 @@ DESCRIPTION = "This library provides useful functions commonly found on BSD syst
HOMEPAGE = "http://libbsd.freedesktop.org/wiki/"
LICENSE = "BSD-4-Clause & MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=f1530ea92aeaa1c5e2547cfd43905d8c"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b99a70657f41053dc4b49d0ae73f7a78"
SECTION = "libs"
DEPENDS = ""
-SRC_URI = "http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
+SRC_URI = " \
+ http://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz \
+ file://0001-Use-local-SHA512-header.patch \
+ "
-SRC_URI[md5sum] = "fcceb4e66fd448ca4ed42ba22a8babb0"
-SRC_URI[sha256sum] = "0f3b0e17e5c34c038126e0a04351b11e23c6101a7d0ce3beeab29bb6415c10bb"
+SRC_URI[md5sum] = "262bdd1aa3bee6066a8c9cb49bb6c584"
+SRC_URI[sha256sum] = "fbb732084bd960e4c78b688aac875be98e290cc6fe462b2ff8ee946a6473e38c"
inherit autotools pkgconfig