aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-01-14 17:42:39 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-28 00:48:23 +0000
commitd8cfe2ce6d45a375449dc3a7370516b8473b0996 (patch)
treebe2c4b6a57a14538d1ae83ae9ead6daf48fb2b77 /meta
parent03ed9095b1ca54a060407f355be0ad9ec86b7610 (diff)
downloadopenembedded-core-contrib-d8cfe2ce6d45a375449dc3a7370516b8473b0996.tar.gz
apr: enable ptest support
Install apr test suite and run it as ptest. Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-support/apr/apr/run-ptest6
-rw-r--r--meta/recipes-support/apr/apr_1.4.8.bb24
2 files changed, 28 insertions, 2 deletions
diff --git a/meta/recipes-support/apr/apr/run-ptest b/meta/recipes-support/apr/apr/run-ptest
new file mode 100644
index 0000000000..ae19a1d11b
--- /dev/null
+++ b/meta/recipes-support/apr/apr/run-ptest
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+cd test
+./testall |sed \
+ -e 's|\(.*\): SUCCESS|PASS: \1|' \
+ -e 's|\(.*\): FAILED|FAIL: \1|'
diff --git a/meta/recipes-support/apr/apr_1.4.8.bb b/meta/recipes-support/apr/apr_1.4.8.bb
index d23929fd4a..4af2a6b0c7 100644
--- a/meta/recipes-support/apr/apr_1.4.8.bb
+++ b/meta/recipes-support/apr/apr_1.4.8.bb
@@ -12,12 +12,14 @@ BBCLASSEXTEND = "native"
SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
file://configure_fixes.patch \
file://cleanup.patch \
- file://configfix.patch"
+ file://configfix.patch \
+ file://run-ptest \
+"
SRC_URI[md5sum] = "ce2ab01a0c3cdb71cf0a6326b8654f41"
SRC_URI[sha256sum] = "61b8d2f8d321c6365ee3d71d0bb41f3a89c44da6124cc5b407a3b8319d660421"
-inherit autotools lib_package binconfig multilib_header
+inherit autotools lib_package binconfig multilib_header ptest
OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
@@ -60,3 +62,21 @@ apr_sysroot_preprocess () {
cp ${S}/build/make_exports.awk $d/
cp ${S}/build/make_var_export.awk $d/
}
+
+do_compile_ptest() {
+ cd ${S}/test
+ oe_runmake
+}
+
+do_install_ptest() {
+ t=${D}${PTEST_PATH}/test
+ mkdir -p $t/.libs
+ cp -r ${S}/test/data $t/
+ cp -r ${S}/test/.libs/*.so $t/.libs/
+ cp ${S}/test/proc_child $t/
+ cp ${S}/test/readchild $t/
+ cp ${S}/test/sockchild $t/
+ cp ${S}/test/sockperf $t/
+ cp ${S}/test/testall $t/
+ cp ${S}/test/tryread $t/
+}