aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKai Kang <kai.kang@windriver.com>2013-06-19 06:33:07 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-06-25 17:30:31 +0100
commite87a0c81c77d11f892a34c2d14ffbeb4342d32dd (patch)
tree4222f35d2ea94b2d53a1ee19e8463c200d1c41e2 /meta
parentf005670ee8f6d02e0b0517a48b47b364f0bddf2d (diff)
downloadopenembedded-core-contrib-e87a0c81c77d11f892a34c2d14ffbeb4342d32dd.tar.gz
python-pygobject: disable parallel install
The installation of __glib.so is invoked by install-data-am target which are generated by automake. installing libpyglib-2.0-python is invoked by install-exec-am. "make install" will firstly install libpyglib-2.0-python, then install __glib.so, the sequence should not be broken, since _glib.so has dependence on libpyglib-2.0-python. But when enable parallel install, the sequence maybe break then installation fails with: "/usr/bin/ld: cannot find -lpyglib-2.0-python" Disable parallel install to fix this issue. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-pygobject_2.27.91.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pygobject_2.27.91.bb b/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
index 3dc2d99483..322521bc20 100644
--- a/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
+++ b/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
@@ -20,6 +20,8 @@ S = "${WORKDIR}/pygobject-${PV}"
FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
EXTRA_OECONF += "--disable-introspection"
+PARALLEL_MAKEINST = ""
+
inherit autotools distutils-base pkgconfig
# necessary to let the call for python-config succeed