summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-04-17 18:15:27 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-04-24 14:06:48 +0100
commit100fce2a65582b9032cb9412fbe8ca572a0549b1 (patch)
tree6e63f09eb27d716482d2bee851c698f32c5d1a66 /meta
parente5d3a6b2fb1fad62dec6389b16fec258df0b573d (diff)
downloadopenembedded-core-contrib-100fce2a65582b9032cb9412fbe8ca572a0549b1.tar.gz
alsa-state: ignore 'No soundcards found' error in pkg_postinst
If there is no soundcards on the target (e.g. qemu), the pkp_postinst function will report an error: alsactl: load_state:1735: No soundcards found... pkg_run_script: package "alsa-state" postinst script returned status 19. opkg_configure: alsa-state.postinst returned 19. Pass '-g' option to alsactl to ignore this error. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/alsa-state/alsa-state.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/alsa-state/alsa-state.bb b/meta/recipes-bsp/alsa-state/alsa-state.bb
index 0670556999..cec2272c80 100644
--- a/meta/recipes-bsp/alsa-state/alsa-state.bb
+++ b/meta/recipes-bsp/alsa-state/alsa-state.bb
@@ -62,7 +62,7 @@ pkg_postinst_${PN}() {
then
if test -x ${sbindir}/alsactl
then
- ${sbindir}/alsactl -f ${localstatedir}/lib/alsa/asound.state restore
+ ${sbindir}/alsactl -g -f ${localstatedir}/lib/alsa/asound.state restore
fi
fi
}