summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTom Rini <tom_rini@mentor.com>2011-07-18 09:19:07 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-21 10:44:33 +0100
commit339d039a9b2f0e97f25781ccf6937f1050d83989 (patch)
tree6ace16f9b98f0c254534493da6592229c8c480f6 /meta
parentdc41f5a453aac2712b60da52f13e6efb035abe02 (diff)
downloadopenembedded-core-contrib-339d039a9b2f0e97f25781ccf6937f1050d83989.tar.gz
python-native: Mangle scripts to use /usr/bin/env python, bump PR
This is dd33ced4b8123600efa1f67f704aec13b0842ad1 in oe.dev and needed for building in deep paths. Signed-off-by: Tom Rini <tom_rini@mentor.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-native_2.6.6.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.6.6.bb b/meta/recipes-devtools/python/python-native_2.6.6.bb
index fa943f4633..59ed61a67a 100644
--- a/meta/recipes-devtools/python/python-native_2.6.6.bb
+++ b/meta/recipes-devtools/python/python-native_2.6.6.bb
@@ -36,4 +36,9 @@ do_install() {
oe_runmake 'DESTDIR=${D}' install
install -d ${D}${bindir}/
install -m 0755 Parser/pgen ${D}${bindir}/
+
+ # Make sure we use /usr/bin/env python
+ for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
+ sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
+ done
}