summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2010-12-13 00:47:29 -0800
committerSaul Wold <sgw@linux.intel.com>2010-12-14 08:53:19 -0800
commit526da3b499d3259c9ded58f7dc9dd20af2985a9c (patch)
treea3034a267c91afde8c7773c926d48fabe203799e /meta
parentb3b25c84e9e6551d6fa0b01111fc1464ca945886 (diff)
downloadopenembedded-core-contrib-526da3b499d3259c9ded58f7dc9dd20af2985a9c.tar.gz
lsbsetup: fix install process
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/lsb/lsbsetup/LSB_Setup.sh (renamed from meta/recipes-extended/lsb/lsb/LSB_Setup.sh)0
-rw-r--r--meta/recipes-extended/lsb/lsbsetup_0.9.bb21
2 files changed, 3 insertions, 18 deletions
diff --git a/meta/recipes-extended/lsb/lsb/LSB_Setup.sh b/meta/recipes-extended/lsb/lsbsetup/LSB_Setup.sh
index 4bf7686c2e..4bf7686c2e 100644
--- a/meta/recipes-extended/lsb/lsb/LSB_Setup.sh
+++ b/meta/recipes-extended/lsb/lsbsetup/LSB_Setup.sh
diff --git a/meta/recipes-extended/lsb/lsbsetup_0.9.bb b/meta/recipes-extended/lsb/lsbsetup_0.9.bb
index f5b40acb8b..ce49fc641c 100644
--- a/meta/recipes-extended/lsb/lsbsetup_0.9.bb
+++ b/meta/recipes-extended/lsb/lsbsetup_0.9.bb
@@ -9,24 +9,9 @@ LIC_FILES_CHKSUM = "file://LSB_Setup.sh;md5=c7360d77e08a7f4f2fa66acf28012e7e"
SRC_URI = "file://LSB_Setup.sh"
-LSBFILE=${POKYBASE}/meta/recipes-extended/lsbsetup/lsb/LSB_Setup.sh
-
S=${WORKDIR}
-do_unpack(){
- cp ${LSBFILE} ${WORKDIR}
-}
-
-
-do_patch(){
- :
-}
-
-do_configure(){
- :
-}
-
-do_install(){
- mkdir -p ${D}/usr/bin
- cp ${LSBFILE} ${D}/usr/bin
+do_install() {
+ # Only install file if it has a contents
+ install -m 0644 ${S}/LSB_Setup.sh ${D}/usr/bin
}