aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/busybox/busybox-1.20.2/strict-atime.patch49
-rw-r--r--meta/recipes-core/busybox/busybox_1.20.2.bb3
2 files changed, 51 insertions, 1 deletions
diff --git a/meta/recipes-core/busybox/busybox-1.20.2/strict-atime.patch b/meta/recipes-core/busybox/busybox-1.20.2/strict-atime.patch
new file mode 100644
index 0000000000..8696427ee8
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox-1.20.2/strict-atime.patch
@@ -0,0 +1,49 @@
+Add support for the "strictatime" mount option.
+
+Upstream-Status: Backport [9ad8979ff15e1b894ee1f4bb6a2535a1a2c20d65]
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+Index: busybox-1.20.2/util-linux/mount.c
+===================================================================
+--- busybox-1.20.2.orig/util-linux/mount.c 2012-07-02 15:08:25.000000000 +0100
++++ busybox-1.20.2/util-linux/mount.c 2013-03-22 15:37:31.340277463 +0000
+@@ -113,6 +113,12 @@
+ #ifndef MS_RELATIME
+ # define MS_RELATIME (1 << 21)
+ #endif
++#ifndef MS_STRICTATIME
++# define MS_STRICTATIME (1 << 24)
++#endif
++
++/* Any ~MS_FOO value has this bit set: */
++#define BB_MS_INVERTED_VALUE (1u << 31)
+
+ #include "libbb.h"
+ #if ENABLE_FEATURE_MOUNT_LABEL
+@@ -239,6 +245,7 @@
+ /* "nomand" */ ~MS_MANDLOCK,
+ /* "relatime" */ MS_RELATIME,
+ /* "norelatime" */ ~MS_RELATIME,
++ /* "strictatime" */ MS_STRICTATIME,
+ /* "loud" */ ~MS_SILENT,
+ /* "rbind" */ MS_BIND|MS_RECURSIVE,
+
+@@ -295,6 +302,7 @@
+ "nomand\0"
+ "relatime\0"
+ "norelatime\0"
++ "strictatime\0"
+ "loud\0"
+ "rbind\0"
+
+@@ -466,8 +474,8 @@
+ // Find this option in mount_options
+ for (i = 0; i < ARRAY_SIZE(mount_options); i++) {
+ if (strcasecmp(option_str, options) == 0) {
+- long fl = mount_options[i];
+- if (fl < 0)
++ unsigned long fl = mount_options[i];
++ if (fl & BB_MS_INVERTED_VALUE)
+ flags &= fl;
+ else
+ flags |= fl;
diff --git a/meta/recipes-core/busybox/busybox_1.20.2.bb b/meta/recipes-core/busybox/busybox_1.20.2.bb
index a02cd38f37..c09a492dbd 100644
--- a/meta/recipes-core/busybox/busybox_1.20.2.bb
+++ b/meta/recipes-core/busybox/busybox_1.20.2.bb
@@ -30,7 +30,8 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://stat-usr-bin.patch \
file://busybox-syslog.service.in \
file://busybox-klogd.service.in \
- file://testsuite-du-du-k-works-fix-false-positive.patch"
+ file://testsuite-du-du-k-works-fix-false-positive.patch \
+ file://strict-atime.patch"
SRC_URI[tarball.md5sum] = "e025414bc6cd79579cc7a32a45d3ae1c"
SRC_URI[tarball.sha256sum] = "eb13ff01dae5618ead2ef6f92ba879e9e0390f9583bd545d8789d27cf39b6882"