aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/sysstat/files/0001-Update-Makefile-to-allow-for-parallel-execution.patch34
-rw-r--r--meta/recipes-extended/sysstat/sysstat.inc3
2 files changed, 36 insertions, 1 deletions
diff --git a/meta/recipes-extended/sysstat/files/0001-Update-Makefile-to-allow-for-parallel-execution.patch b/meta/recipes-extended/sysstat/files/0001-Update-Makefile-to-allow-for-parallel-execution.patch
new file mode 100644
index 0000000000..c82b19cf10
--- /dev/null
+++ b/meta/recipes-extended/sysstat/files/0001-Update-Makefile-to-allow-for-parallel-execution.patch
@@ -0,0 +1,34 @@
+Upstream-Status: Backport
+Signed-off-by: Roy.Li <rongqing.li@windriver.com>
+
+From eb44730094a68f4d37d95ddc3480a5972619b43f Mon Sep 17 00:00:00 2001
+From: Sebastien GODARD <sysstat@orange.fr.fake>
+Date: Sat, 22 Jun 2013 14:08:40 +0200
+Subject: [PATCH] Update Makefile to allow for parallel execution
+
+Rewrite rule for librdstats.a in Makefile to prevent possible file
+corruption when using make -j.
+
+Signed-off-by: Sebastien GODARD <sysstat@orange.fr.fake>
+---
+ Makefile.in | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index f8e6159..159cacf 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -202,7 +202,9 @@ sadf_misc.o: sadf_misc.c sadf.h sa.h
+ libsyscom.a: common.o ioconf.o
+ $(AR) rvs $@ $?
+
+-librdstats.a: librdstats.a(rd_stats.o count.o)
++# Ditto
++librdstats.a: rd_stats.o count.o
++ $(AR) rvs $@ $?
+
+ librdsensors.a: librdsensors.a(rd_sensors.o)
+
+--
+1.7.10.4
+
diff --git a/meta/recipes-extended/sysstat/sysstat.inc b/meta/recipes-extended/sysstat/sysstat.inc
index 263cbd247c..ac3c89be3c 100644
--- a/meta/recipes-extended/sysstat/sysstat.inc
+++ b/meta/recipes-extended/sysstat/sysstat.inc
@@ -5,7 +5,8 @@ LICENSE = "GPLv2+"
SECTION = "console/utils"
SRC_URI = "http://pagesperso-orange.fr/sebastien.godard/sysstat-${PV}.tar.gz \
- file://99_sysstat"
+ file://99_sysstat \
+ file://0001-Update-Makefile-to-allow-for-parallel-execution.patch "
inherit autotools gettext