aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/python/python3/python3-manifest.json11
-rw-r--r--meta/recipes-devtools/python/python3_3.5.5.bb5
2 files changed, 16 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/python3-manifest.json b/meta/recipes-devtools/python/python3/python3-manifest.json
index 3dda9f6e10..54a91dfe83 100644
--- a/meta/recipes-devtools/python/python3/python3-manifest.json
+++ b/meta/recipes-devtools/python/python3/python3-manifest.json
@@ -1079,6 +1079,17 @@
],
"summary": "Python Tcl/Tk bindings"
},
+ "tools": {
+ "cached": [],
+ "files": [
+ "${docdir}/${PN}/Tools"
+ ],
+ "rdepends": [
+ "core",
+ "modules"
+ ],
+ "summary": "Useful scripts from Python"
+ },
"typing": {
"cached": [
"${libdir}/python3.5/__pycache__/typing.*.pyc"
diff --git a/meta/recipes-devtools/python/python3_3.5.5.bb b/meta/recipes-devtools/python/python3_3.5.5.bb
index 17e8245356..a43ce0027b 100644
--- a/meta/recipes-devtools/python/python3_3.5.5.bb
+++ b/meta/recipes-devtools/python/python3_3.5.5.bb
@@ -196,6 +196,11 @@ do_install() {
fi
oe_multilib_header python${PYTHON_BINABI}/pyconfig.h
+
+ # Install tools
+ install -d -m 755 ${D}/${docdir}/${PN}
+ cp -r ${S}/Tools ${D}/${docdir}/${PN}/
+ find ${D}/${docdir}/${PN}/ -name Makefile -delete
}
do_install_append_class-nativesdk () {