summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xmeta/packages/psplash/files/psplash-init7
-rw-r--r--meta/packages/psplash/psplash_svn.bb2
2 files changed, 7 insertions, 2 deletions
diff --git a/meta/packages/psplash/files/psplash-init b/meta/packages/psplash/files/psplash-init
index a966638074..e2c6bf8f5d 100755
--- a/meta/packages/psplash/files/psplash-init
+++ b/meta/packages/psplash/files/psplash-init
@@ -12,5 +12,10 @@ done
export TMPDIR=/mnt/.psplash
mount tmpfs -t tmpfs $TMPDIR -o,size=40k
-/usr/bin/psplash &
+rotation=0
+if [ -e /etc/rotation ]; then
+ rotation=`cat /etc/rotation`
+fi
+
+/usr/bin/psplash --angle=$rotation &
diff --git a/meta/packages/psplash/psplash_svn.bb b/meta/packages/psplash/psplash_svn.bb
index 5ac42f9ec7..4066c6b3fb 100644
--- a/meta/packages/psplash/psplash_svn.bb
+++ b/meta/packages/psplash/psplash_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Userspace framebuffer boot logo based on usplash."
SECTION = "base"
LICENSE = "GPL"
PV = "0.0+svn${SRCDATE}"
-PR = "r1"
+PR = "r2"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=psplash;proto=http \
file://psplash-init"