aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/grub/grub_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/grub/grub_git.bb')
-rw-r--r--meta/recipes-bsp/grub/grub_git.bb13
1 files changed, 8 insertions, 5 deletions
diff --git a/meta/recipes-bsp/grub/grub_git.bb b/meta/recipes-bsp/grub/grub_git.bb
index 6a0e3ee036..3ebab7f2f8 100644
--- a/meta/recipes-bsp/grub/grub_git.bb
+++ b/meta/recipes-bsp/grub/grub_git.bb
@@ -5,13 +5,14 @@ DEPENDS += "autogen-native"
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_arm = "1"
+FILESEXTRAPATHS =. "${FILE_DIRNAME}/grub-git:"
+
PV = "2.00+${SRCPV}"
-SRCREV = "87de66d9d83446ecddb29cfbdf7369102c8e209e"
+SRCREV = "b95e92678882f56056c64ae29092bc9cf129905f"
SRC_URI = "git://git.savannah.gnu.org/grub.git \
- file://grub-2.00-fpmath-sse-387-fix.patch \
+ file://0001-Disable-mfpmath-sse-as-well-when-SSE-is-disabled.patch \
file://autogen.sh-exclude-pc.patch \
- file://grub-2.00-add-oe-kernel.patch \
- file://0001-Fix-build-with-glibc-2.20.patch \
+ file://0001-grub.d-10_linux.in-add-oe-s-kernel-name.patch \
"
S = "${WORKDIR}/git"
@@ -30,6 +31,8 @@ GRUBPLATFORM ??= "pc"
EXTRA_OECONF = "--with-platform=${GRUBPLATFORM} --disable-grub-mkfont --program-prefix="" \
--enable-liblzma=no --enable-device-mapper=no --enable-libzfs=no"
+EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '--enable-largefile ac_cv_sizeof_off_t=8', '--disable-largefile', d)}"
+
do_configure_prepend() {
( cd ${S}
${S}/autogen.sh )
@@ -37,7 +40,7 @@ do_configure_prepend() {
do_install_append () {
install -d ${D}${sysconfdir}/grub.d
-
+ rm -rf ${D}${libdir}/charset.alias
}
# debugedit chokes on bare metal binaries