aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/connman/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/connman/files')
-rwxr-xr-xmeta/recipes-connectivity/connman/files/connman42
-rw-r--r--meta/recipes-connectivity/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch13
-rw-r--r--meta/recipes-connectivity/connman/files/connman-install-tests.patch15
-rw-r--r--meta/recipes-connectivity/connman/files/dbusperms.patch12
-rw-r--r--meta/recipes-connectivity/connman/files/udevfix.patch12
5 files changed, 94 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/connman/files/connman b/meta/recipes-connectivity/connman/files/connman
new file mode 100755
index 0000000000..f8154f68f9
--- /dev/null
+++ b/meta/recipes-connectivity/connman/files/connman
@@ -0,0 +1,42 @@
+#!/bin/sh
+
+DAEMON=/usr/sbin/connmand
+PIDFILE=/var/run/connmand.pid
+DESC="Connection Manager"
+
+if [ -f /etc/default/connman ] ; then
+ . /etc/default/connman
+fi
+
+set -e
+
+do_start() {
+ $DAEMON
+}
+
+do_stop() {
+ start-stop-daemon --stop --name connmand --quiet
+}
+
+case "$1" in
+ start)
+ echo "Starting $DESC"
+ do_start
+ ;;
+ stop)
+ echo "Stopping $DESC"
+ do_stop
+ ;;
+ restart|force-reload)
+ echo "Restarting $DESC"
+ do_stop
+ sleep 1
+ do_start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart|force-reload}" >&2
+ exit 1
+ ;;
+esac
+
+exit 0
diff --git a/meta/recipes-connectivity/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch b/meta/recipes-connectivity/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch
new file mode 100644
index 0000000000..57df7196ec
--- /dev/null
+++ b/meta/recipes-connectivity/connman/files/connman-install-tests-d52de88aff4771283b2ebee4f48a7af15862d0ae.patch
@@ -0,0 +1,13 @@
+Index: git/test/Makefile.am
+===================================================================
+--- git.orig/test/Makefile.am 2009-05-21 12:07:39.000000000 +0100
++++ git/test/Makefile.am 2009-05-21 17:29:33.000000000 +0100
+@@ -1,5 +1,7 @@
+
+-EXTRA_DIST = get-state list-profiles list-services \
++testdir = $(pkgdatadir)/tests
++
++test_SCRIPTS = get-state list-profiles list-services \
+ list-connections select-connection \
+ list-devices enable-device disable-device start-scanning \
+ list-networks select-network disable-network create-network \
diff --git a/meta/recipes-connectivity/connman/files/connman-install-tests.patch b/meta/recipes-connectivity/connman/files/connman-install-tests.patch
new file mode 100644
index 0000000000..0ea3758f2d
--- /dev/null
+++ b/meta/recipes-connectivity/connman/files/connman-install-tests.patch
@@ -0,0 +1,15 @@
+Index: git/Makefile.am
+===================================================================
+--- git.orig/Makefile.am 2009-08-24 15:56:33.000000000 +0100
++++ git/Makefile.am 2009-08-24 16:02:38.000000000 +0100
+@@ -115,7 +115,9 @@
+ tools_wifi_scan_LDADD = @GLIB_LIBS@ @NETLINK_LIBS@
+ endif
+
+-EXTRA_DIST += test/get-state test/list-profiles test/list-services \
++testdir = $(pkgdatadir)/tests
++
++test_SCRIPTS = test/get-state test/list-profiles test/list-services \
+ test/connect-service test/list-connections \
+ test/select-connection test/list-devices test/enable-device \
+ test/disable-device test/start-scanning test/list-networks \
diff --git a/meta/recipes-connectivity/connman/files/dbusperms.patch b/meta/recipes-connectivity/connman/files/dbusperms.patch
new file mode 100644
index 0000000000..100af0367b
--- /dev/null
+++ b/meta/recipes-connectivity/connman/files/dbusperms.patch
@@ -0,0 +1,12 @@
+Index: git/src/connman-dbus.conf
+===================================================================
+--- git.orig/src/connman-dbus.conf 2009-05-26 00:34:35.000000000 +0100
++++ git/src/connman-dbus.conf 2009-05-26 00:34:48.000000000 +0100
+@@ -10,6 +10,6 @@
+ <allow send_destination="org.moblin.connman"/>
+ </policy>
+ <policy context="default">
+- <deny send_destination="org.moblin.connman"/>
++ <allow send_destination="org.moblin.connman"/>
+ </policy>
+ </busconfig>
diff --git a/meta/recipes-connectivity/connman/files/udevfix.patch b/meta/recipes-connectivity/connman/files/udevfix.patch
new file mode 100644
index 0000000000..803bec5281
--- /dev/null
+++ b/meta/recipes-connectivity/connman/files/udevfix.patch
@@ -0,0 +1,12 @@
+Index: git/src/connman.rules
+===================================================================
+--- git.orig/src/connman.rules 2009-05-25 14:24:53.000000000 +0100
++++ git/src/connman.rules 2009-05-25 14:25:16.000000000 +0100
+@@ -3,6 +3,7 @@
+
+ SUBSYSTEM=="net", KERNEL=="eth*", ENV{CONNMAN_TYPE}="ethernet"
+ SUBSYSTEM=="net", KERNEL=="wlan*", ENV{CONNMAN_TYPE}="wifi"
++SUBSYSTEM=="net", KERNEL=="ra0", ENV{CONNMAN_TYPE}="wifi"
+
+ SUBSYSTEM=="net", DRIVERS=="hso", ENV{CONNMAN_TYPE}="hso"
+