aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb')
-rw-r--r--meta/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb b/meta/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb
new file mode 100644
index 0000000000..84eed373f7
--- /dev/null
+++ b/meta/recipes-connectivity/telepathy/telepathy-gabble_0.7.8.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Jabber/XMPP connection manager"
+HOMEPAGE = "http://telepathy.freedesktop.org/wiki/"
+DEPENDS = "glib-2.0 dbus loudmouth telepathy-glib dbus-glib"
+LICENSE = "LGPL"
+
+# gabble.manager needs to get regenerated every release, so please don't copy it over blindly
+SRC_URI = "http://telepathy.freedesktop.org/releases/telepathy-gabble/${P}.tar.gz \
+ file://gabble.manager"
+
+inherit autotools pkgconfig
+
+do_compile_prepend() {
+ cp ${WORKDIR}/gabble.manager ${S}/data/
+}
+
+FILES_${PN} += "${datadir}/telepathy \
+ ${datadir}/dbus-1"