summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ifupdown/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/ifupdown/files')
-rw-r--r--meta/recipes-core/ifupdown/files/0001-Define-FNM_EXTMATCH-for-musl.patch47
-rw-r--r--meta/recipes-core/ifupdown/files/0001-Makefile-do-not-use-dpkg-for-determining-OS-type.patch23
-rw-r--r--meta/recipes-core/ifupdown/files/0001-ifupdown-skip-wrong-test-case.patch32
-rw-r--r--meta/recipes-core/ifupdown/files/defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch8
-rw-r--r--meta/recipes-core/ifupdown/files/inet-6-.defn-fix-inverted-checks-for-loopback.patch406
-rw-r--r--meta/recipes-core/ifupdown/files/run-ptest4
-rw-r--r--meta/recipes-core/ifupdown/files/tweak-ptest-script.patch54
7 files changed, 164 insertions, 410 deletions
diff --git a/meta/recipes-core/ifupdown/files/0001-Define-FNM_EXTMATCH-for-musl.patch b/meta/recipes-core/ifupdown/files/0001-Define-FNM_EXTMATCH-for-musl.patch
new file mode 100644
index 0000000000..7bf02ea536
--- /dev/null
+++ b/meta/recipes-core/ifupdown/files/0001-Define-FNM_EXTMATCH-for-musl.patch
@@ -0,0 +1,47 @@
+From ff714d6461569d69b253089110ec659e4ebec248 Mon Sep 17 00:00:00 2001
+From: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
+Date: Tue, 2 Jul 2019 20:10:42 +0200
+Subject: [PATCH] Define FNM_EXTMATCH for musl
+
+Fixes the following compilation errors with musl that does not have
+FNM_EXTMATCH defined:
+
+| main.c: In function 'expand_matches':
+| main.c:700:40: error: 'FNM_EXTMATCH' undeclared (first use in this
+function); did you mean 'FNM_NOMATCH'?
+| 700 | if(fnmatch(pattern, ifa->ifa_name, FNM_EXTMATCH))
+| | ^~~~~~~~~~~~
+| | FNM_NOMATCH
+
+and
+
+| archlinux.c:40:28: error: 'FNM_EXTMATCH' undeclared (first use in this
+function); did you mean 'FNM_NOMATCH'?
+| 40 | if(fnmatch(pattern, buf, FNM_EXTMATCH) == 0) {
+| | ^~~~~~~~~~~~
+| | FNM_NOMATCH
+
+Upstream-Status: Submitted [https://salsa.debian.org/debian/ifupdown/merge_requests/5]
+
+Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com>
+---
+ archcommon.h | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/archcommon.h b/archcommon.h
+index fe99950..f257f9d 100644
+--- a/archcommon.h
++++ b/archcommon.h
+@@ -1,5 +1,9 @@
+ #include "header.h"
+
++#if !defined(FNM_EXTMATCH)
++#define FNM_EXTMATCH 0
++#endif
++
+ bool execable(const char *);
+
+ #define iface_is_link() (!_iface_has(ifd->real_iface, ":."))
+--
+2.17.1
+
diff --git a/meta/recipes-core/ifupdown/files/0001-Makefile-do-not-use-dpkg-for-determining-OS-type.patch b/meta/recipes-core/ifupdown/files/0001-Makefile-do-not-use-dpkg-for-determining-OS-type.patch
new file mode 100644
index 0000000000..57c8d04fd7
--- /dev/null
+++ b/meta/recipes-core/ifupdown/files/0001-Makefile-do-not-use-dpkg-for-determining-OS-type.patch
@@ -0,0 +1,23 @@
+From 7ace0656bd325f9e7749f2cde641eddc057bc98a Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex.kanavin@gmail.com>
+Date: Thu, 9 Jan 2020 15:38:06 +0100
+Subject: [PATCH] Makefile: do not use dpkg for determining OS type
+
+Upstream-Status: Inappropriate [oe-core specific]
+Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 0ce2fa3..739aef2 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ VERSION ?= 0.8
+ CFLAGS ?= -Wall -W -Wno-unused-parameter -g -O2
+-ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
++ARCH := linux
+
+ BASEDIR ?= $(DESTDIR)
+
diff --git a/meta/recipes-core/ifupdown/files/0001-ifupdown-skip-wrong-test-case.patch b/meta/recipes-core/ifupdown/files/0001-ifupdown-skip-wrong-test-case.patch
new file mode 100644
index 0000000000..c751e4fab0
--- /dev/null
+++ b/meta/recipes-core/ifupdown/files/0001-ifupdown-skip-wrong-test-case.patch
@@ -0,0 +1,32 @@
+From 98243deface88614e3f332c4a85d04a9abce55ff Mon Sep 17 00:00:00 2001
+From: Zqiang <qiang.zhang@windriver.com>
+Date: Mon, 19 Apr 2021 14:15:45 +0800
+Subject: [PATCH] ifupdown: skip wrong test case
+
+The test parameters of testcase(12-15) file is not right,
+it triggers a test failure, these test items are invalid
+and are skipped directly.
+
+Upstream-Status: Inappropriate [oe-core specific]
+
+Signed-off-by: Zqiang <qiang.zhang@windriver.com>
+---
+ tests/testbuild-linux | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/testbuild-linux b/tests/testbuild-linux
+index 1181ea0..5f148eb 100755
+--- a/tests/testbuild-linux
++++ b/tests/testbuild-linux
+@@ -3,7 +3,7 @@
+ dir=tests/linux
+
+ result=true
+-for test in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18; do
++for test in 1 2 3 4 5 6 7 8 9 10 11 16 17 18; do
+ if [ -e $dir/testcase.$test ]; then
+ args="$(cat $dir/testcase.$test | sed -n 's/^# RUN: //p')"
+ else
+--
+2.17.1
+
diff --git a/meta/recipes-core/ifupdown/files/defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch b/meta/recipes-core/ifupdown/files/defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch
index a24b8cda66..d1c3d260ed 100644
--- a/meta/recipes-core/ifupdown/files/defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch
+++ b/meta/recipes-core/ifupdown/files/defn2-c-man-don-t-rely-on-dpkg-architecture-to-set-a.patch
@@ -1,4 +1,4 @@
-From 7af9db748974cb3a2c6ef8f9e03d7db1f9f8ee16 Mon Sep 17 00:00:00 2001
+From 40257d65b338b6e2ed9d89d6fa7c7b8701a4c311 Mon Sep 17 00:00:00 2001
From: Paul Gortmaker <paul.gortmaker@windriver.com>
Date: Wed, 6 Aug 2014 14:54:12 -0400
Subject: [PATCH 1/2] defn2[c|man]: don't rely on dpkg-architecture to set arch
@@ -19,7 +19,7 @@ Upstream-Status: Pending
2 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/defn2c.pl b/defn2c.pl
-index c449de2f3d1c..38845e374c76 100755
+index 8798dc2..f2551c7 100755
--- a/defn2c.pl
+++ b/defn2c.pl
@@ -2,9 +2,9 @@
@@ -36,7 +36,7 @@ index c449de2f3d1c..38845e374c76 100755
# declarations
my $address_family = "";
diff --git a/defn2man.pl b/defn2man.pl
-index 6ddcfdd4fe68..c9c4dd046597 100755
+index 6ddcfdd..c9c4dd0 100755
--- a/defn2man.pl
+++ b/defn2man.pl
@@ -2,9 +2,9 @@
@@ -53,5 +53,5 @@ index 6ddcfdd4fe68..c9c4dd046597 100755
# declarations
my $line;
--
-1.9.1
+2.17.1
diff --git a/meta/recipes-core/ifupdown/files/inet-6-.defn-fix-inverted-checks-for-loopback.patch b/meta/recipes-core/ifupdown/files/inet-6-.defn-fix-inverted-checks-for-loopback.patch
deleted file mode 100644
index 37a61c9bc1..0000000000
--- a/meta/recipes-core/ifupdown/files/inet-6-.defn-fix-inverted-checks-for-loopback.patch
+++ /dev/null
@@ -1,406 +0,0 @@
-From 7efe4676747e4e4a056b9bfb4e9424c8354e9996 Mon Sep 17 00:00:00 2001
-From: "Maxin B. John" <maxin.john@intel.com>
-Date: Wed, 21 Dec 2016 15:32:07 +0200
-Subject: [PATCH] inet[6].defn: fix inverted checks for loopback
-
-Compared to the hurd link.defn for loopback, we see these
-are inverted, meaning that you would only be able to configure
-a loopback device that was _not_ named "lo" (unlikely to exist).
-
-The result was that we'd update /run/network/ifstate for "lo"
-but never actually do anything for up/down, as shown below:
-
-root@localhost:~# ifconfig -s
-Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
-eth0 1500 0 7736329 0 2016 0 5289422 0 0 0 BMRU
-lo 65536 0 18 0 0 0 18 0 0 0 LRU
-root@localhost:~# ifdown lo
-root@localhost:~# echo $?
-0
-root@localhost:~# ifconfig -s
-Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
-eth0 1500 0 7736406 0 2016 0 5289455 0 0 0 BMRU
-lo 65536 0 18 0 0 0 18 0 0 0 LRU
-root@localhost:~# ifconfig lo down
-root@localhost:~# ifconfig -s
-Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
-eth0 1500 0 7736474 0 2016 0 5289481 0 0 0 BMRU
-root@localhost:~#
-
-Also reverted the commit:
-commit 80b878497663dae08f70b4d3cffe127b57a3cfc
-which uses absolute paths to binaries called by ifup/ifdown.
-
-Upstream-Status: Inappropriate [OE specific]
-
-Signed-off-by: Paul Gortmaker <paul.gortmaker@windriver.com>
-Signed-off-by: Maxin B. John <maxin.john@intel.com>
-Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
----
- inet.defn | 140 +++++++++++++++++++++++++++++++-------------------------------
- 1 file changed, 70 insertions(+), 70 deletions(-)
-
-diff --git a/inet.defn b/inet.defn
-index 75e6744..23c7756 100644
---- a/inet.defn
-+++ b/inet.defn
-@@ -6,10 +6,10 @@ method loopback
- This method may be used to define the IPv4 loopback interface.
-
- up
-- /bin/ip link set dev %iface% up if (!iface_is_lo())
-+ ip link set dev %iface% up if (!iface_is_lo())
-
- down
-- /bin/ip link set dev %iface% down if (!iface_is_lo())
-+ ip link set dev %iface% down if (!iface_is_lo())
-
- method static
- description
-@@ -36,17 +36,17 @@ method static
- broadcast compute_v4_broadcast
-
- up
-- /bin/ip addr add %address%[[/%netmask%]] [[broadcast %broadcast%]] \
-+ ip addr add %address%[[/%netmask%]] [[broadcast %broadcast%]] \
- [[peer %pointopoint%]] [[scope %scope%]] dev %iface% label %iface%
-- /bin/ip link set dev %iface% [[mtu %mtu%]] [[address %hwaddress%]] up
-+ ip link set dev %iface% [[mtu %mtu%]] [[address %hwaddress%]] up
-
-- [[ /bin/ip route add default via %gateway% [[metric %metric%]] dev %iface% onlink ]]
-+ [[ ip route add default via %gateway% [[metric %metric%]] dev %iface% onlink ]]
-
- down
-- [[ /bin/ip route del default via %gateway% [[metric %metric%]] dev %iface% 2>&1 1>/dev/null || true ]]
-- /bin/ip addr del %address%[[/%netmask%]] [[broadcast %broadcast%]] \
-+ [[ ip route del default via %gateway% [[metric %metric%]] dev %iface% 2>&1 1>/dev/null || true ]]
-+ ip addr del %address%[[/%netmask%]] [[broadcast %broadcast%]] \
- [[peer %pointopoint%]] [[scope %scope%]] dev %iface% label %iface%
-- /bin/ip link set dev %iface% down \
-+ ip link set dev %iface% down \
- if (iface_is_link())
-
- method manual
-@@ -63,12 +63,12 @@ method manual
- hwaddress cleanup_hwaddress
-
- up
-- [[/bin/ip link set dev %iface% mtu %mtu%]]
-- [[/bin/ip link set dev %iface% address %hwaddress%]]
-- /bin/ip link set dev %iface% up 2>/dev/null || true
-+ [[ip link set dev %iface% mtu %mtu%]]
-+ [[ip link set dev %iface% address %hwaddress%]]
-+ ip link set dev %iface% up 2>/dev/null || true
-
- down
-- /bin/ip link set dev %iface% down 2>/dev/null || true \
-+ ip link set dev %iface% down 2>/dev/null || true \
- if (iface_is_link() && !do_all)
-
- method dhcp
-@@ -93,33 +93,33 @@ method dhcp
- hwaddress cleanup_hwaddress
-
- up
-- [[/bin/ip link set dev %iface% address %hwaddress%]]
-- /sbin/dhclient -v -pf /run/dhclient.%iface%.pid -lf /var/lib/dhcp/dhclient.%iface%.leases -I -df /var/lib/dhcp/dhclient6.%iface%.leases %iface% \
-+ [[ip link set dev %iface% address %hwaddress%]]
-+ dhclient -v -pf /run/dhclient.%iface%.pid -lf /var/lib/dhcp/dhclient.%iface%.leases -I -df /var/lib/dhcp/dhclient6.%iface%.leases %iface% \
- [[-e IF_METRIC=%metric%]] \
- if (execable("/sbin/dhclient"))
-- /sbin/pump -i %iface% [[-h %hostname%]] [[-l %leasehours%]] \
-+ pump -i %iface% [[-h %hostname%]] [[-l %leasehours%]] \
- elsif (execable("/sbin/pump"))
-- /sbin/udhcpc -n -p /run/udhcpc.%iface%.pid -i %iface% [[-x hostname:%hostname%]] \
-+ udhcpc -n -p /run/udhcpc.%iface%.pid -i %iface% [[-x hostname:%hostname%]] \
- elsif (execable("/sbin/udhcpc"))
-- /sbin/dhcpcd [[-h %hostname%]] [[-i %vendor%]] [[-I %client%]] \
-+ dhcpcd [[-h %hostname%]] [[-i %vendor%]] [[-I %client%]] \
- [[-l %leasetime%]] [[-m %metric%]] %iface% \
- elsif (execable("/sbin/dhcpcd"))
- echo 'No DHCP client software found!' >/dev/stderr; false \
- elsif (1)
-
- down
-- /sbin/dhclient -v -r -pf /run/dhclient.%iface%.pid -lf /var/lib/dhcp/dhclient.%iface%.leases -I -df /var/lib/dhcp/dhclient6.%iface%.leases %iface% \
-+ dhclient -v -r -pf /run/dhclient.%iface%.pid -lf /var/lib/dhcp/dhclient.%iface%.leases -I -df /var/lib/dhcp/dhclient6.%iface%.leases %iface% \
- if (execable("/sbin/dhclient"))
-- /sbin/pump -i %iface% -r \
-+ pump -i %iface% -r \
- elsif (execable("/sbin/pump"))
-- if test -f /run/udhcpc.%iface%.pid; then kill -USR2 $(/bin/cat /run/udhcpc.%iface%.pid); kill -TERM $(/bin/cat /run/udhcpc.%iface%.pid); fi \
-+ if test -f /run/udhcpc.%iface%.pid; then kill -USR2 $(cat /run/udhcpc.%iface%.pid); kill -TERM $(cat /run/udhcpc.%iface%.pid); fi \
- elsif (execable("/sbin/udhcpc"))
-- /sbin/dhcpcd -k %iface% \
-+ dhcpcd -k %iface% \
- elsif (execable("/sbin/dhcpcd"))
- echo 'No DHCP client software found!' >/dev/stderr; false \
- elsif (1)
-
-- /bin/ip link set dev %iface% down \
-+ ip link set dev %iface% down \
- if (iface_is_link())
-
- method bootp
-@@ -134,11 +134,11 @@ method bootp
- whatever it really is.
-
- up
-- /sbin/bootpc [[--bootfile %bootfile%]] --dev %iface% [[--server %server%]] \
-+ bootpc [[--bootfile %bootfile%]] --dev %iface% [[--server %server%]] \
- [[--hwaddr %hwaddr%]] --returniffail --serverbcast
-
- down
-- /bin/ip link set dev %iface% down \
-+ ip link set dev %iface% down \
- if (iface_is_link())
-
- method tunnel
-@@ -158,13 +158,13 @@ method tunnel
- ttl time -- TTL setting
- mtu size -- MTU size
- up
-- /bin/ip tunnel add %iface% mode %mode% remote %endpoint% [[local %local%]] \
-+ ip tunnel add %iface% mode %mode% remote %endpoint% [[local %local%]] \
- [[ttl %ttl%]]
-- /bin/ip link set %iface% up [[mtu %mtu%]]
-- /bin/ip addr add %address%/%netmask% dev %iface% [[peer %dstaddr%]]
-- [[ /bin/ip route add default via %gateway% [[metric %metric%]] dev %iface% onlink ]]
-+ ip link set %iface% up [[mtu %mtu%]]
-+ ip addr add %address%/%netmask% dev %iface% [[peer %dstaddr%]]
-+ [[ ip route add default via %gateway% [[metric %metric%]] dev %iface% onlink ]]
- down
-- /bin/ip tunnel del %iface%
-+ ip tunnel del %iface%
-
- method ppp
- description
-@@ -175,9 +175,9 @@ method ppp
- unit number -- Use /number/ as the ppp unit number.
- options string -- Pass /string/ as additional options to pon.
- up
-- /usr/bin/pon [[%provider%]] [[unit %unit%]] [[%options%]]
-+ pon [[%provider%]] [[unit %unit%]] [[%options%]]
- down
-- /usr/bin/poff [[%provider%]]
-+ poff [[%provider%]]
-
- method wvdial
- description
-@@ -186,10 +186,10 @@ method wvdial
- options
- provider name -- Use /name/ as the provider (from /etc/wvdial.conf).
- up
-- /sbin/start-stop-daemon --start -x /usr/bin/wvdial \
-+ start-stop-daemon --start -x /usr/bin/wvdial \
- -p /run/wvdial.%iface%.pid -b -m -- [[ %provider% ]]
- down
-- /sbin/start-stop-daemon --stop -x /usr/bin/wvdial \
-+ start-stop-daemon --stop -x /usr/bin/wvdial \
- -p /run/wvdial.%iface%.pid -s 2
-
-
-@@ -200,9 +200,9 @@ method ipv4ll
- known as APIPA or IPAC, and often colloquially referred to
- as "Zeroconf address".
- up
-- /usr/sbin/avahi-autoipd -D %iface%
-+ avahi-autoipd -D %iface%
- down
-- /usr/sbin/avahi-autoipd --kill %iface%
-+ avahi-autoipd --kill %iface%
-
- architecture kfreebsd
-
-@@ -211,11 +211,11 @@ method loopback
- This method may be used to define the IPv4 loopback interface.
-
- up
-- /sbin/ifconfig %iface% 127.0.0.1 up \
-+ ifconfig %iface% 127.0.0.1 up \
- if (!iface_is_lo())
-
- down
-- /sbin/ifconfig %iface% down \
-+ ifconfig %iface% down \
- if (!iface_is_lo())
-
- method static
-@@ -238,15 +238,15 @@ method static
- hwaddress cleanup_hwaddress
-
- up
-- [[ /sbin/ifconfig %iface% link %hwaddress%]]
-- /sbin/ifconfig %iface% %address% [[netmask %netmask%]] [[broadcast %broadcast%]] \
-+ [[ ifconfig %iface% link %hwaddress%]]
-+ ifconfig %iface% %address% [[netmask %netmask%]] [[broadcast %broadcast%]] \
- [[pointopoint %pointopoint%]] [[media %media%]] [[mtu %mtu%]] \
- up
-- [[ /sbin/route add default %gateway% ]]
-+ [[ route add default %gateway% ]]
-
- down
-- [[ /sbin/route del default %gateway% 2>&1 1>/dev/null || true ]]
-- /sbin/ifconfig %iface% down
-+ [[ route del default %gateway% 2>&1 1>/dev/null || true ]]
-+ ifconfig %iface% down
-
- method manual
- description
-@@ -279,30 +279,30 @@ method dhcp
- hwaddress cleanup_hwaddress
-
- up
-- [[/sbin/ifconfig %iface% link %hwaddress%]]
-- /sbin/dhclient -v -pf /run/dhclient.%iface%.pid -lf /var/lib/dhcp/dhclient.%iface%.leases -I -df /var/lib/dhcp/dhclient6.%iface%.leases %iface% \
-+ [[ifconfig %iface% link %hwaddress%]]
-+ dhclient -v -pf /run/dhclient.%iface%.pid -lf /var/lib/dhcp/dhclient.%iface%.leases -I -df /var/lib/dhcp/dhclient6.%iface%.leases %iface% \
- [[-e IF_METRIC=%metric%]] \
- if (execable("/sbin/dhclient"))
-- /sbin/udhcpc -n -p /run/udhcpc.%iface%.pid -i %iface% [[-H %hostname%]] \
-+ udhcpc -n -p /run/udhcpc.%iface%.pid -i %iface% [[-H %hostname%]] \
- [[-c %client%]] \
- elsif (execable("/sbin/udhcpc"))
-- /sbin/dhcpcd [[-h %hostname%]] [[-i %vendor%]] [[-I %client%]] \
-+ dhcpcd [[-h %hostname%]] [[-i %vendor%]] [[-I %client%]] \
- [[-l %leasetime%]] %iface% \
- elsif (execable("/sbin/dhcpcd"))
- echo 'No DHCP client software found!' >/dev/stderr; false \
- elsif (1)
-
- down
-- /sbin/dhclient -v -r -pf /run/dhclient.%iface%.pid -lf /var/lib/dhcp/dhclient.%iface%.leases -I -df /var/lib/dhcp/dhclient6.%iface%.leases %iface% \
-+ dhclient -v -r -pf /run/dhclient.%iface%.pid -lf /var/lib/dhcp/dhclient.%iface%.leases -I -df /var/lib/dhcp/dhclient6.%iface%.leases %iface% \
- if (execable("/sbin/dhclient"))
-- if test -f /run/udhcpc.%iface%.pid; then kill -USR2 $(/bin/cat /run/udhcpc.%iface%.pid); kill -TERM $(/bin/cat /run/udhcpc.%iface%.pid); fi \
-+ if test -f /run/udhcpc.%iface%.pid; then kill -USR2 $(cat /run/udhcpc.%iface%.pid); kill -TERM $(cat /run/udhcpc.%iface%.pid); fi \
- elsif (execable("/sbin/udhcpc"))
-- /sbin/dhcpcd -k %iface% \
-+ dhcpcd -k %iface% \
- elsif (execable("/sbin/dhcpcd"))
- echo 'No DHCP client software found!' >/dev/stderr; false \
- elsif (1)
-
-- /sbin/ifconfig %iface% down
-+ ifconfig %iface% down
-
- method bootp
- description
-@@ -316,11 +316,11 @@ method bootp
- whatever it really is.
-
- up
-- /sbin/bootpc [[--bootfile %bootfile%]] --dev %iface% [[--server %server%]] \
-+ bootpc [[--bootfile %bootfile%]] --dev %iface% [[--server %server%]] \
- [[--hwaddr %hwaddr%]] --returniffail --serverbcast
-
- down
-- /sbin/ifconfig %iface% down
-+ ifconfig %iface% down
-
- method ppp
- description
-@@ -331,9 +331,9 @@ method ppp
- unit number -- Use /number/ as the ppp unit number.
- options string -- Pass /string/ as additional options to pon.
- up
-- /usr/bin/pon [[%provider%]] [[unit %unit%]] [[%options%]]
-+ pon [[%provider%]] [[unit %unit%]] [[%options%]]
- down
-- /usr/bin/poff [[%provider%]]
-+ poff [[%provider%]]
-
- method wvdial
- description
-@@ -342,10 +342,10 @@ method wvdial
- options
- provider name -- Use /name/ as the provider (from /etc/wvdial.conf).
- up
-- /sbin/start-stop-daemon --start -x /usr/bin/wvdial \
-+ start-stop-daemon --start -x /usr/bin/wvdial \
- -p /run/wvdial.%iface%.pid -b -m -- [[ %provider% ]]
- down
-- /sbin/start-stop-daemon --stop -x /usr/bin/wvdial \
-+ start-stop-daemon --stop -x /usr/bin/wvdial \
- -p /run/wvdial.%iface%.pid -s 2
-
-
-@@ -356,9 +356,9 @@ method ipv4ll
- known as APIPA or IPAC, and often colloquially referred to
- as "Zeroconf address".
- up
-- /usr/sbin/avahi-autoipd -D %iface%
-+ avahi-autoipd -D %iface%
- down
-- /usr/sbin/avahi-autoipd --kill %iface%
-+ avahi-autoipd --kill %iface%
- architecture hurd
-
- method loopback
-@@ -432,23 +432,23 @@ method dhcp
-
- up
- [[Warning: Option hwaddress: %hwaddress% not yet supported]]
-- /sbin/dhclient -v -pf /run/dhclient.%iface///.%.pid -lf /var/lib/dhcp/dhclient.%iface///.%.leases -I -df /var/lib/dhcp/dhclient6.%iface///.%.leases %iface% \
-+ dhclient -v -pf /run/dhclient.%iface///.%.pid -lf /var/lib/dhcp/dhclient.%iface///.%.leases -I -df /var/lib/dhcp/dhclient6.%iface///.%.leases %iface% \
- if (execable("/sbin/dhclient"))
-- /sbin/udhcpc -n -p /run/udhcpc.%iface///.%.pid -i %iface% [[-H %hostname%]] \
-+ udhcpc -n -p /run/udhcpc.%iface///.%.pid -i %iface% [[-H %hostname%]] \
- [[-c %client%]] \
- elsif (execable("/sbin/udhcpc"))
-- /sbin/dhcpcd [[-h %hostname%]] [[-i %vendor%]] [[-I %client%]] \
-+ dhcpcd [[-h %hostname%]] [[-i %vendor%]] [[-I %client%]] \
- [[-l %leasetime%]] %iface% \
- elsif (execable("/sbin/dhcpcd"))
- echo 'No DHCP client software found!' >/dev/stderr; false \
- elsif (1)
-
- down
-- /sbin/dhclient -v -r -pf /run/dhclient.%iface///.%.pid -lf /var/lib/dhcp/dhclient.%iface///.%.leases -I -df /var/lib/dhcp/dhclient6.%iface///.%.leases %iface% \
-+ dhclient -v -r -pf /run/dhclient.%iface///.%.pid -lf /var/lib/dhcp/dhclient.%iface///.%.leases -I -df /var/lib/dhcp/dhclient6.%iface///.%.leases %iface% \
- if (execable("/sbin/dhclient"))
-- if test -f /run/udhcpc.%iface///.%.pid; then kill -USR2 $(/bin/cat /run/udhcpc.%iface///.%.pid); kill -TERM $(/bin/cat /run/udhcpc.%iface///.%.pid); fi \
-+ if test -f /run/udhcpc.%iface///.%.pid; then kill -USR2 $(cat /run/udhcpc.%iface///.%.pid); kill -TERM $(cat /run/udhcpc.%iface///.%.pid); fi \
- elsif (execable("/sbin/udhcpc"))
-- /sbin/dhcpcd -k %iface% \
-+ dhcpcd -k %iface% \
- elsif (execable("/sbin/dhcpcd"))
- echo 'No DHCP client software found!' >/dev/stderr; false \
- elsif (1)
-@@ -482,9 +482,9 @@ method ppp
- unit number -- Use /number/ as the ppp unit number.
- options string -- Pass /string/ as additional options to pon.
- up
-- /usr/bin/pon [[%provider%]] [[unit %unit%]] [[%options%]]
-+ pon [[%provider%]] [[unit %unit%]] [[%options%]]
- down
-- /usr/bin/poff [[%provider%]]
-+ poff [[%provider%]]
-
- method wvdial
- description
-@@ -493,10 +493,10 @@ method wvdial
- options
- provider name -- Use /name/ as the provider (from /etc/wvdial.conf).
- up
-- /sbin/start-stop-daemon --start -x /usr/bin/wvdial \
-+ start-stop-daemon --start -x /usr/bin/wvdial \
- -p /run/wvdial.%iface///.%.pid -b -m -- [[ %provider% ]]
- down
-- /sbin/start-stop-daemon --stop -x /usr/bin/wvdial \
-+ start-stop-daemon --stop -x /usr/bin/wvdial \
- -p /run/wvdial.%iface///.%.pid -s 2
-
-
-@@ -507,6 +507,6 @@ method ipv4ll
- known as APIPA or IPAC, and often colloquially referred to
- as "Zeroconf address".
- up
-- /usr/sbin/avahi-autoipd -D %iface%
-+ avahi-autoipd -D %iface%
- down
-- /usr/sbin/avahi-autoipd --kill %iface%
-+ avahi-autoipd --kill %iface%
---
-2.7.4
-
diff --git a/meta/recipes-core/ifupdown/files/run-ptest b/meta/recipes-core/ifupdown/files/run-ptest
new file mode 100644
index 0000000000..8694042392
--- /dev/null
+++ b/meta/recipes-core/ifupdown/files/run-ptest
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+CURDIR=$(dirname `readlink -f $0`)
+cd $CURDIR/tests && ./testbuild-linux
diff --git a/meta/recipes-core/ifupdown/files/tweak-ptest-script.patch b/meta/recipes-core/ifupdown/files/tweak-ptest-script.patch
new file mode 100644
index 0000000000..ea88a9086a
--- /dev/null
+++ b/meta/recipes-core/ifupdown/files/tweak-ptest-script.patch
@@ -0,0 +1,54 @@
+Tweak tests of ifupdown to make it work with oe-core ptest framework.
+
+Upstream-Status: Inappropriate [oe-core specific]
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+ tests/testbuild-linux | 11 ++++++-----
+ 1 file changed, 6 insertions(+), 5 deletions(-)
+
+diff --git a/tests/testbuild-linux b/tests/testbuild-linux
+index 5f148eb..d9b1698 100755
+--- a/tests/testbuild-linux
++++ b/tests/testbuild-linux
+@@ -1,6 +1,7 @@
+ #!/bin/sh -e
+
+-dir=tests/linux
++curdir=$(dirname `readlink -f $0`)
++dir=$curdir/linux
+
+ result=true
+ for test in 1 2 3 4 5 6 7 8 9 10 11 16 17 18; do
+@@ -12,7 +13,7 @@ for test in 1 2 3 4 5 6 7 8 9 10 11 16 17 18; do
+ echo "Testcase $test: $args"
+
+ exitcode=0
+- ./ifup -v --no-act-commands --force -i $dir/testcase.$test --state-dir=$dir/state.$test $args \
++ ifup -v --no-act-commands --force -i $dir/testcase.$test --state-dir=$dir/state.$test $args \
+ >$dir/up-res-out.$test 2>$dir/up-res-err.$test || exitcode=$?
+
+ (echo "exit code: $exitcode";
+@@ -20,7 +21,7 @@ for test in 1 2 3 4 5 6 7 8 9 10 11 16 17 18; do
+ echo "====stderr===="; cat $dir/up-res-err.$test) > $dir/up-res.$test
+
+ exitcode=0
+- ./ifdown -v --no-act-commands --force -i $dir/testcase.$test --state-dir=$dir/state.$test $args \
++ ifdown -v --no-act-commands --force -i $dir/testcase.$test --state-dir=$dir/state.$test $args \
+ >$dir/down-res-out.$test 2>$dir/down-res-err.$test || exitcode=$?
+
+ (echo "exit code: $exitcode";
+@@ -28,9 +29,9 @@ for test in 1 2 3 4 5 6 7 8 9 10 11 16 17 18; do
+ echo "====stderr===="; cat $dir/down-res-err.$test) > $dir/down-res.$test
+
+ if diff -ub $dir/up.$test $dir/up-res.$test && diff -ub $dir/down.$test $dir/down-res.$test; then
+- echo "(okay)"
++ echo "PASS: $test"
+ else
+- echo "(failed)"
++ echo "FAIL: $test"
+ result=false
+ fi
+ echo "=========="
+--
+2.17.1