summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd_243.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd_243.bb')
-rw-r--r--meta/recipes-core/systemd/systemd_243.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-core/systemd/systemd_243.bb b/meta/recipes-core/systemd/systemd_243.bb
index 3ae1516dfb..f0e8c569b8 100644
--- a/meta/recipes-core/systemd/systemd_243.bb
+++ b/meta/recipes-core/systemd/systemd_243.bb
@@ -298,6 +298,11 @@ do_install() {
install -Dm 0644 ${WORKDIR}/99-default.preset ${D}${systemd_unitdir}/system-preset/99-default.preset
}
+do_install_append () {
+ # Mips qemu is extremely slow, allow more time for the hwdb update
+ # This is a workaround until https://github.com/systemd/systemd/issues/13581 is resolved
+ sed -i -e s#TimeoutSec=90s#TimeoutSec=180s# ${D}${systemd_unitdir}/system/systemd-hwdb-update.service
+}
python populate_packages_prepend (){
systemdlibdir = d.getVar("rootlibdir")