aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/automake/automake_1.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/automake/automake_1.11.1.bb')
-rw-r--r--meta/recipes-devtools/automake/automake_1.11.1.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.11.1.bb b/meta/recipes-devtools/automake/automake_1.11.1.bb
new file mode 100644
index 0000000000..a78b6901f1
--- /dev/null
+++ b/meta/recipes-devtools/automake/automake_1.11.1.bb
@@ -0,0 +1,41 @@
+require automake.inc
+
+DEPENDS_virtclass-native = "autoconf-native"
+
+RDEPENDS_automake += "\
+ autoconf \
+ perl \
+ perl-module-bytes \
+ perl-module-constant \
+ perl-module-cwd \
+ perl-module-data-dumper \
+ perl-module-dynaloader \
+ perl-module-errno \
+ perl-module-exporter-heavy \
+ perl-module-file-basename \
+ perl-module-file-compare \
+ perl-module-file-copy \
+ perl-module-file-glob \
+ perl-module-file-spec-unix \
+ perl-module-file-stat \
+ perl-module-getopt-long \
+ perl-module-io \
+ perl-module-io-file \
+ perl-module-posix \
+ perl-module-strict \
+ perl-module-text-parsewords \
+ perl-module-vars "
+
+RDEPENDS_automake-native = "autoconf-native perl-native-runtime"
+
+PATHFIXPATCH = "file://path_prog_fixes.patch;patch=1"
+PATHFIXPATCH_virtclass-native = ""
+
+SRC_URI += "${PATHFIXPATCH}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+ install -d ${D}${datadir}
+}
+
+BBCLASSEXTEND = "native"